Author Topic: can't view in hex mode  (Read 3117 times)

mcswell

  • Junior Community Member
  • Posts: 2
  • Hero Points: 0
can't view in hex mode
« on: January 29, 2007, 03:32:40 am »
I have a file that I can't view in Hex mode--the View | Hex menu option is grayed out, as are most of the other items in the View menu.  Typing 'hex' on the cmd line gives the msg 'Command is disabled for this object'.  Of possible relevance: this is a UTF-8 file (although I don't see why that would prevent it from being viewed as hex).

Suggestions?

VSlick 8.0.1.

   Mike Maxwell

jbhurst

  • Senior Community Member
  • Posts: 405
  • Hero Points: 33
Re: can't view in hex mode
« Reply #1 on: January 29, 2007, 07:16:34 pm »
Hex editing is not supported for Unicode files.

You may be able to turn on hex mode if you open the file with encoding "Binary, SBCS/DBCS" (in the File Open dialog). This works in SlickEdit 12 beta ... I don't know if it is available with SlickEdit 8.

Regards

John Hurst

mcswell

  • Junior Community Member
  • Posts: 2
  • Hero Points: 0
Re: can't view in hex mode
« Reply #2 on: January 29, 2007, 08:08:12 pm »
I guess I can understand why you might discourage hex editing in UTF-8: if you make a mistake, it could have repercussions downstream.  But I would be happy if it allowed at least read-only viewing in hex mode.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4485
  • Hero Points: 345
Re: can't view in hex mode
« Reply #3 on: January 30, 2007, 03:24:41 pm »
In newer versions (V11, not sure about V10), you can flip into hex editing mode for unicode files that have UTF-8 encoding.  The reason SlickEdit does not switch into hex mode for other encoding is that internally SlickEdit translates all unicode to Utf-8.  So if the original file was Utf-16, switching to hex mode would display Utf-8 data and not Utf-16.