Author Topic: Turn off "smart" next-word & prev-word  (Read 1419 times)

skeller@co-kellers.com

  • Junior Community Member
  • Posts: 3
  • Hero Points: 0
Turn off "smart" next-word & prev-word
« on: June 10, 2014, 05:24:10 pm »
I just recently upgraded to Slickedit 2013 from a much older version.  And I used the CUA emulation mode in both versions.  One of the things I've noticed about 2013 that is different from my older version is that when I press <ctrl> left arrow or <ctrl> right arrow to advance to next or previous word the cursor does not always go to the start of the word.  How do I get it to always go to the start of the word?

thanks,
Spence

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2664
  • Hero Points: 410
Re: Turn off "smart" next-word & prev-word
« Reply #1 on: June 10, 2014, 10:41:28 pm »
I'm guessing what you are running into is the sub-word navigation (Tools > Options > Editing > Cursor Movement > Subword Navigation > ON

Turn it off to always navigate to whole words.

Code: [Select]
SubWordNavigationStopsHere     // wow
^  ^   ^         ^    ^           ^
WholeWordNavigationStopsHere   // fantastic
^                                 ^
« Last Edit: June 10, 2014, 10:43:15 pm by Dennis »

skeller@co-kellers.com

  • Junior Community Member
  • Posts: 3
  • Hero Points: 0
Re: Turn off "smart" next-word & prev-word
« Reply #2 on: June 12, 2014, 03:43:32 pm »
Actually I needed to turn it off.  Thank you VERY much!