Author Topic: Long time slickedit user and things are not looking good  (Read 3851 times)

saheemg

  • Junior Community Member
  • Posts: 5
  • Hero Points: 0
Long time slickedit user and things are not looking good
« on: July 11, 2014, 04:59:09 pm »
I have been using slickedit for many years and I always thought it was great. (Even got my new employer to purchase me a license despite them having multiple options for an editor readily available.)  These last two releases or so, I am starting to see the quality dropping off.  Here are a couple of things (hopefully its really user error and someone can help me resolve them).

First here is my version info:
lickEdit 2013 (v18.0.1.2 64-bit)

Serial number: WB946738
Licensed number of users: Single user
License file: C:\ProgramData\slickedit\18\slickedit.lic

Build Date: August 12, 2013
Emulation: CUA

Now my problems
Backup history: Randomly decides when to create history.  Sometimes it does and sometimes even after multiple saves it only shows version 0.  I have been using integrated FTP client for files.  I wonder if that plays a role.  (I am pretty sure I have backup history configured properly.)

DIFF: This is the most painful.  Sometimes I am at a difference and all of the "block" and "line"buttons are all grey. Or when it should allow me to delete the block, it doesn't.  Or worse when I say press "Line" it actually copies the string "Imaginary Buffer Line".  Its all so random, I have no idea what to expect.

When I do ctrl-tab, the behavior is basically random.  This started a few releases ago.  I remember a time when I did a ctrl-tab it always went back to the window I just worked on first.  I have played with the Smart Next Window option and I have never got it back to the way it was.  Now ctrl-tab takes me to a random file (not even the next window in the window table toolbar.)

FIND/REPLACE: This occurred on a previous install of this same version.  It is better now, but listing here anyway. When I did a ctrl-f or ctrl-r, the text value in the Search for text field was already highlighted.  This allowed me to to a ctrl-f and just start typing to enter string to search for.  All of sudden this change. I would have to do a ctrl-f and then use mouse to select text to overwrite, and then type search string.  When you do a lot of searches this is royal pain.  It also would never remember the last text I searched for.  (again this is not happening since a clean install)

I hope all of these issues are things I can resolve.  Unfortunately I am coming to point where I am considering using another editor. 

Tim Kemp

  • Senior Community Member
  • Posts: 533
  • Hero Points: 90
Re: Long time slickedit user and things are not looking good
« Reply #1 on: July 11, 2014, 06:04:59 pm »
To solve your search and replace issue, try turning on, "Selected text (if exists)":

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4627
  • Hero Points: 370
Re: Long time slickedit user and things are not looking good
« Reply #2 on: July 11, 2014, 06:28:34 pm »
Backup history. Try creating a new file, make various edits and saves. Then test the backup history dialog to see if things are working. If there are problems with this, contact SlickEdit support. If things only go wrong with some existing files you have, send SlickEdit support the .vsdelta file. In the mean time, you will want to delete the offending .vsdelta to get your history working again for that file.

DIFF. Not much for us to go on here. We could really use some reproducable steps.

Ctrl-tab: Go to Tools>Options>Editor Windows>Files per window. Make sure "Files per window" is set to "One file per window". If Ctrl+Tab never works, please provide steps to reproduce the problem you see. Just post the steps in this thread.

FIND/REPLACE: The macro variable (def_focus_select) controls whether text fields are selected when focus changes. It sounds like the macro variable got turned off some how but you corrected it by reinstalling. Just set this macro variable to 1. I looked around the macro source and the only case where this is turned off is a pretty remote case on Unix.

saheemg

  • Junior Community Member
  • Posts: 5
  • Hero Points: 0
Re: Long time slickedit user and things are not looking good
« Reply #3 on: July 12, 2014, 02:14:45 pm »
I see .vsdelta files for many files, but nothing jumps out at me for the files I edit using the integrated FTP client.  Is backup history not support for FTP files?   Oddly I see backup history for some files I open/save via FTP client and others no.

Could my odd diff behavior be tied to the backup history issue?  I think I see most diff problems when using backup history to compare versions. I don't recall if I see problems when using diff otherwise.

Backup history. Try creating a new file, make various edits and saves. Then test the backup history dialog to see if things are working. If there are problems with this, contact SlickEdit support. If things only go wrong with some existing files you have, send SlickEdit support the .vsdelta file. In the mean time, you will want to delete the offending .vsdelta to get your history working again for that file.

DIFF. Not much for us to go on here. We could really use some reproducable steps.

Ctrl-tab: Go to Tools>Options>Editor Windows>Files per window. Make sure "Files per window" is set to "One file per window". If Ctrl+Tab never works, please provide steps to reproduce the problem you see. Just post the steps in this thread.

FIND/REPLACE: The macro variable (def_focus_select) controls whether text fields are selected when focus changes. It sounds like the macro variable got turned off some how but you corrected it by reinstalling. Just set this macro variable to 1. I looked around the macro source and the only case where this is turned off is a pretty remote case on Unix.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4627
  • Hero Points: 370
Re: Long time slickedit user and things are not looking good
« Reply #4 on: July 13, 2014, 10:06:17 pm »
Now that you've posted that backup history doesn't work for FTP files, I'm not surprised. I'm not sure how hard it will be to make it work. I'll have someone look into it. When you edit an FTP file using the FTP client, the document name you see and the buffer name (filename for disk) are not at all the same. The buffer name is some sort of temp file name.

It's hard to say whether the odd diff behavior you are seeing has something to do with the FTP backup history issue. In any case, if you find a reproducible problem with diffing in backup history and can provide us with the .vsdelta file, we will look into it. Just contact support and give them the file and steps to reproduce.

saheemg

  • Junior Community Member
  • Posts: 5
  • Hero Points: 0
Re: Long time slickedit user and things are not looking good
« Reply #5 on: July 15, 2014, 01:07:07 pm »
I did find the vsdelta files for some of the ftp files, but not for all.  Again, it seems like sometimes it backs up ftp files while other times it doesn't.

Now that you've posted that backup history doesn't work for FTP files, I'm not surprised. I'm not sure how hard it will be to make it work. I'll have someone look into it. When you edit an FTP file using the FTP client, the document name you see and the buffer name (filename for disk) are not at all the same. The buffer name is some sort of temp file name.

It's hard to say whether the odd diff behavior you are seeing has something to do with the FTP backup history issue. In any case, if you find a reproducible problem with diffing in backup history and can provide us with the .vsdelta file, we will look into it. Just contact support and give them the file and steps to reproduce.

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2265
  • Hero Points: 127
Re: Long time slickedit user and things are not looking good
« Reply #6 on: July 21, 2014, 07:54:04 pm »
Can you find a file where it consistently doesn't work?

I tested this and the vsdelta files do go to a consistent, predictable location.  The names do get very long though, and the length limit for a filename on Windows is 260 characters.  So I'm a little concerned that could be the problem.  If you can find a consistent case where they don't get backed up, we should be able to figure out if that's the problem pretty easily.

saheemg

  • Junior Community Member
  • Posts: 5
  • Hero Points: 0
Re: Long time slickedit user and things are not looking good
« Reply #7 on: July 22, 2014, 01:38:17 pm »
I think the 260 limit may be the problem.  I have an FTP filename with length of 216 characters.  If that name is concatenated to the location of the backup history path, I can easily get over 260 characters.  Any suggestions on how to get around 260 limit?


Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2265
  • Hero Points: 127
Re: Long time slickedit user and things are not looking good
« Reply #8 on: July 22, 2014, 06:02:00 pm »
Does this file fail to have backups?

To answer your question, I will try to put in some code to shorten the path.  But in the meantime you could specify a backup path that is shorter than the path to your configuration and that will help.  Go to Tools>Options>File Options>Backup>Backup directory path.  I use "c:\deltabackups".

saheemg

  • Junior Community Member
  • Posts: 5
  • Hero Points: 0
Re: Long time slickedit user and things are not looking good
« Reply #9 on: July 22, 2014, 06:32:14 pm »
If the file name is too long, I don't see backups created.

Different question:  To get around this problem, I tried using WebDrive.  Essentially it makes a FTP site look like a network drive.  I had to abandon webdrive because slickedit would constantly hang up.  In most cases, eventually it would come back.  I suspected it was refreshing and because I had too many files open from the WebDrive and even tagged files using webdrive it was holding everything up.  So I removed the tagged files, had no files open from the webdrive and made sure the current directory in slick edit was not in webdrive either.  Yet it continued to hang up.  The only way it would stop is if I disconnected the webdrive.  Any ideas why slickedit would hang up? 

Phil Barila

  • Senior Community Member
  • Posts: 742
  • Hero Points: 61
Re: Long time slickedit user and things are not looking good
« Reply #10 on: July 22, 2014, 07:35:02 pm »
@Dan, you'll do better to use the long file path hack (http://msdn.microsoft.com/en-us/library/windows/desktop/aa365247%28v=vs.85%29.aspx).  It's a hack, but it does work.

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2265
  • Hero Points: 127
Re: Long time slickedit user and things are not looking good
« Reply #11 on: August 15, 2014, 02:02:35 pm »
DIFF: This is the most painful.  Sometimes I am at a difference and all of the "block" and "line"buttons are all grey. Or when it should allow me to delete the block, it doesn't.  Or worse when I say press "Line" it actually copies the string "Imaginary Buffer Line".  Its all so random, I have no idea what to expect.

I was able to identify a problem here, it will be fixed in the next hotfix.