Author Topic: Fun test of Slicks multilingual abilities  (Read 2041 times)

jporkkahtc

  • Senior Community Member
  • Posts: 2195
  • Hero Points: 192
  • Text
Fun test of Slicks multilingual abilities
« on: August 07, 2014, 05:53:42 pm »
http://ideology.com.au/polyglot/polyglot.txt

This is a source file that is valid code in 8 different languages :-)

Slick does pretty well, but you have to adjust some options (for example, turn off comment nesting in Pascal).
Cobol: Slick doesn't handle the left and right magins quite right, not that I'm a cobol expert, but I think that anything in 1...7 and 73...80 should be ignored - esentially a comment. Slick doesn't do that for 73...80. It sort of does for the first 7 columns. It does better in Fortran though.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5779
  • Hero Points: 461
Re: Fun test of Slicks multilingual abilities
« Reply #1 on: August 07, 2014, 06:48:28 pm »
Supporting columns for unicode Cobol is more complicated than counting unicode characters. One of our OEMS implemented the  appropriate SlickEdit API callbacks to handle the most complicated scenario. We could probably ship simple unicode support which counts characters but this is useless for most COBOL source. I'm talking about ancient IBM mainframe code page source that's been converted to Unicode. Fun!!

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3251
  • Hero Points: 462
Re: Fun test of Slicks multilingual abilities
« Reply #2 on: August 11, 2014, 02:23:22 pm »
We have three separate COBOL language modes.  Handling the columns better might be as simple as Document > Select Mode... > Cobol 74.

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3251
  • Hero Points: 462
Re: Fun test of Slicks multilingual abilities
« Reply #3 on: August 11, 2014, 02:48:04 pm »
I checked in a tweak to make the Cobol 74 color coding get things right.  The tagging had it, but the color coding was missing a setting for line comments past column 74.

Pascal works right, but you have to turn off the Delphi extension to allow nested (* comments.