Author Topic: Strip trailing spaces option is not working  (Read 2710 times)

Praveen Kumar

  • Community Member
  • Posts: 15
  • Hero Points: 0
Strip trailing spaces option is not working
« on: August 19, 2014, 05:49:57 am »
Even though I selecting "Strip all trailing spaces" in slickedit preferences, slickedit is not stripping the spaces effectively.

Phil Barila

  • Senior Community Member
  • Posts: 746
  • Hero Points: 61
Re: Strip trailing spaces option is not working
« Reply #1 on: August 19, 2014, 12:22:07 pm »
Does it work when you actually save the file?  In the SE editor, it often leaves extra trailing spaces as the editor is doing it's thing, especially in comment blocks.  When the file is saved, however, the trailing spaces are removed.

Lee

  • Moderator
  • Senior Community Member
  • *
  • Posts: 1070
  • Hero Points: 91
Re: Strip trailing spaces option is not working
« Reply #2 on: August 19, 2014, 01:21:31 pm »
Thanks for the report.  It does appear that the trailing spaces aren't being stripped beyond the Truncation line column.  I will have to see if there is a workaround for this.

Praveen Kumar

  • Community Member
  • Posts: 15
  • Hero Points: 0
Re: Strip trailing spaces option is not working
« Reply #3 on: August 20, 2014, 12:05:07 am »
Thanks Phil Barila and Lee :-)

Lee@: Yes, I confirmed the 'stripping trailing spaces' fails only for the spaces beyond the truncation line column. Switching 'ON' the Windows->SlickEdit Preferences->Truncation Line Length breaks few other things as well.

1. Strip Trailing Spaces
2. Copy/Paste issue
3. Line Numbering issue
4. coding on next line issue   

Please find the attached animated image for better understanding.



Lee

  • Moderator
  • Senior Community Member
  • *
  • Posts: 1070
  • Hero Points: 91
Re: Strip trailing spaces option is not working
« Reply #4 on: August 20, 2014, 12:51:10 pm »
I can definitely say there are still some quirks with the Truncation line enabled.  Thanks for the video,  I will take a look at it and see what can be done for the next update.

Lee

  • Moderator
  • Senior Community Member
  • *
  • Posts: 1070
  • Hero Points: 91
Re: Strip trailing spaces option is not working
« Reply #5 on: August 20, 2014, 04:16:33 pm »
1 and 3 are definitely reproducible issues and should be fixable.

As for 2, that the intended behavior.  It will not allow you to paste a clipboard that would go beyond the truncation line.

And could you go into more detail on issue 4?  I can't exactly make out what is going on there.  And it appears there is a mix of tabs and spaces, but I can't seem to reproduce it.

Praveen Kumar

  • Community Member
  • Posts: 15
  • Hero Points: 0
Re: Strip trailing spaces option is not working
« Reply #6 on: August 21, 2014, 03:34:58 am »
Hi Lee,

Thanks for your update!!
Let me explain you the issue 4 now,

Issue 4: when I coding assembly instruction in the second line by hitting Enter from the first line, I'm getting the unwanted spaces between each character I code.


Steps to recreate:

1. Open a file in the slickedit editor.
2. Select the file mode as IBM HLASM ( Format->select mode->IBM HLASM ) and
3. Hit <tab>+<tab> and code any instruction say MVC TEST,TEST then hit enter
4. Type MVC TEST1,TEST1 - here when you type this instruction you'll get the unwanted spaces in between the instruction(This is the issue).