Author Topic: Open file (Ctrl-O) Behavior  (Read 1218 times)

shadm

  • Community Member
  • Posts: 48
  • Hero Points: 0
Open file (Ctrl-O) Behavior
« on: August 21, 2014, 04:43:39 pm »
OS: Linux
OS Version: Ubuntu 12.04.5 LTS
Kernel Level: 3.2.0-67-generic
Build Version: #101-Ubuntu SMP Tue Jul 15 17:46:11 UTC 2014
Processor Architecture: x86_64


Just installed the first beta.  Here are some different/bad behaviors that I've seen so far:

  • When I want to open a file using Ctrl-O to open the open file dialog, the cursor/focus is somewhere useless.  I have to then resort to grabbing my mouse and specifically selecting the text box to enter the file name I would like to open.
  • In the past, if should change my mind about opening a file, I could simply hit the escape button to close the file open dialog.  Now it seems to cause focus to return to the window I started from.
  • When I have a file open in a separate window and hit Ctrl-O to open a file, the dialog is docked inside the floating window.  In all these exercises, I have deselected the option for the window to be dockable.

Rodney

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 717
  • Hero Points: 46
Re: Open file (Ctrl-O) Behavior
« Reply #1 on: August 21, 2014, 04:50:42 pm »
This will be fixed. Thanks for the report.

++rodney

shadm

  • Community Member
  • Posts: 48
  • Hero Points: 0
Re: Open file (Ctrl-O) Behavior (B5 update)
« Reply #2 on: September 25, 2014, 02:22:41 pm »
In beta 5, the second bullet seems to have come back.  If I click on Ctrl-O to open the open dialog (after I have deselected the "dockable" option) and then change my mind about opening a file, and hit escape, the Open dialog does not close.  It does put the focus back on the editor.

Rodney

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 717
  • Hero Points: 46
Re: Open file (Ctrl-O) Behavior
« Reply #3 on: September 25, 2014, 05:14:35 pm »
Fixed for the next build. Thanks.

++rodney

shadm

  • Community Member
  • Posts: 48
  • Hero Points: 0
Re: Open file (Ctrl-O) Behavior (B6 Update)
« Reply #4 on: October 01, 2014, 04:57:10 pm »
I think the ESC to close is now fixed.  However, when I open the dialog, the "Name" column is sized so small I can not see the file names, so I have to divert my hand from the keyboard to the mouse to resize the column so I can see the file names and then go back and select the textbox to type.  After I select a file, the dialog dismisses as I would expect.  Next time I open the dialog, the "Name" column is again so small it is unusable.  Sometimes it is completely collapsed, sometimes I can see a character or two.

Rodney

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 717
  • Hero Points: 46
Re: Open file (Ctrl-O) Behavior
« Reply #5 on: October 01, 2014, 07:48:02 pm »
Since nobody here can reproduce this with the latest beta, some questions:
1. Are you sure you're running the latest beta (beta 6 as of this post)?
2. I also run Ubuntu 12.04 with Unity. Are you running an different window manager?
3. If you run with a clean config (e.g. 'vs -sc ~/testconfig') do you still see the problem?

++rodney

shadm

  • Community Member
  • Posts: 48
  • Hero Points: 0
Re: Open file (Ctrl-O) Behavior
« Reply #6 on: October 01, 2014, 08:48:35 pm »
1. I am running:

SlickEdit 2014 (v19.0.0.9 64-bit)

Serial number: FE12899_BETA
License type: Beta License
License expiration: 2014-10-05 06:14:00
License file: /opt/slickedit_2014_beta6/bin/slickedit.lic

Build Date: September 29, 2014
Emulation: Visual Studio

OS: Linux
OS Version: Ubuntu 12.04.5 LTS
Kernel Level: 3.2.0-68-generic
Build Version: #102-Ubuntu SMP Tue Aug 12 22:02:15 UTC 2014
Processor Architecture: x86_64

X Server Vendor: The X.Org Foundation
Memory: 95% Load, 5609MB/5901MB Virtual
Shell Info: /opt/slickedit_2014_beta6/bin/secsh -i
Screen Size: 1920 x 1200, 1920 x 1200

Project Type: No project open
Language: .0 (Plain Text)


2. I run Ubuntu 12.04 with KDE.  I think Unity is the thing I hate about Gnome, which is why I run KDE.  There are no processes by the name of unity running.

3. I launched a clean config according to your example, and see the same behavior.

Before I posted the update today, I removed all previous beta versions and installed B6 as an upgrade to my original v2013 install.  And in case it is not clear, I am using the "Smart Open" option, not the other one.  Let me know if I can provide any additional information.