Author Topic: B2 MAC SlickC Stack during perl debugging  (Read 2396 times)

tuchman

  • Senior Community Member
  • Posts: 136
  • Hero Points: 7
B2 MAC SlickC Stack during perl debugging
« on: September 03, 2014, 03:28:21 pm »
B2 seems to behave much better than B1 with regard to perl debugging. 
I have been able to start and (almost) complete stepping into, stepping around, going in a complex perl project.  However:
1) At the very end of the program and debug session, I got a SlickC stack (see below).
2) After the SlickC stack, my tool windows were all blown away! 
3) (2) distracted me from seeing how often the SlickC stack issue can be reproduced, as I couldn't seem to restore the file tabs without having a very large gray area below the tab. I finally was able to resize the tabs window and eliminate the gray area.
4) But now the tabs window is too narrow - it doesn't fill the entire edit window space.
(Edit)
5) Continued perl debugging has continued to mess up tool windows.  Please see strange screen shot attached.


Thanks,
-ken

mainwindow.ex 2077 mainwindow:_autorestore_from_view(15,0)   p_window_id: 15   p_object: OI_EDITOR   p_name:
mainwindow.ex 3026 debug_switch_mode(0,0)   p_window_id: 42 (invalid)
tbview.ex 305 tbDebugSwitchMode(0,0)   p_window_id: 42 (invalid)
debug.ex 851 debug_maybe_stop_debugging()   p_window_id: 42 (invalid)
debug.ex 9646 debug_stop(1,0)   p_window_id: 42 (invalid)
debug.ex 23694 debug:debug_session_update_debugger(1,exit,8,0,,0,0,0,0,0,0,0,0,0,0)   p_window_id: 42 (invalid)
debug.ex 25791 _UpdateDebugger(0)   p_window_id: 42 (invalid)
autosave.ex 555 _as_callback()   p_window_id: 42 (invalid)
« Last Edit: September 03, 2014, 03:48:37 pm by tuchman »

Rodney

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 739
  • Hero Points: 47
Re: B2 MAC SlickC Stack during perl debugging
« Reply #1 on: September 03, 2014, 03:54:37 pm »
I can reproduce the sizing issue. Still trying to reproduce the stack. On Windows right now, so will have to try on Mac later.

++rodney

tuchman

  • Senior Community Member
  • Posts: 136
  • Hero Points: 7
Re: B2 MAC SlickC Stack during perl debugging
« Reply #2 on: September 21, 2014, 12:17:31 pm »
The same problem has also happened on Win7-64 using SE B5. 
It's a bit hard to reproduce - It's happened twice while starting perl debugging out of ~100 debug sessions.  Each time I get the Slick-C stack, some or all of my tools window setup is blown away, and I have to reconfigure the windows :-(. 

Edit:  Just happened again on Windows...

Edit: Just happened again...
 Invalid argument
mainwindow.ex 2136 mainwindow:_autorestore_from_view(16,0)   p_window_id: 16   p_object: OI_EDITOR   p_name:
mainwindow.ex 2923 debug_switch_mode(1,0)   p_window_id: 425   p_object: OI_EDITOR   p_name:
tbview.ex 305 tbDebugSwitchMode(1,0)   p_window_id: 425   p_object: OI_EDITOR   p_name:
debug.ex 444 activate_debug(perl5db,,,,30,<empty>, -socket=1536  -feature-set=show_hidden=0 -feature-set=max_children=32,<empty>)   p_window_id: 425   p_object: OI_EDITOR   p_name:
debug.ex 1008 debug_begin(perl5db,,,,30,<empty>, -socket=1536  -feature-set=show_hidden=0 -feature-set=max_children=32,<empty>)   p_window_id: 425   p_object: OI_EDITOR   p_name:
perlopts.ex 2124 _perl_project_command_status(3,Debug,1536,perl_debug,debug,D:\data\CI\V61\deltaT.pl,slurp,go,1,)   p_window_id: 425   p_object: OI_EDITOR   p_name:
compile.ex 6621 _project_command(debug,D:\data\CI\V61\deltaT.pl,slurp,0,1,0,0,go)   p_window_id: 425   p_object: OI_EDITOR   p_name:
compile.ex 1784 _project_command2(debug,0,1,0,0,go,D:\data\CI\V61\deltaT.pl)   p_window_id: 425   p_object: OI_EDITOR   p_name:
compile.ex 1444 _project_debug2(0,go)   p_window_id: 425   p_object: OI_EDITOR   p_name:
debug.ex 1516 debug_go(0)   p_window_id: 425   p_object: OI_EDITOR   p_name:
compile.ex 1238 project_debug()   p_window_id: 425   p_object: OI_EDITOR   p_name:
picture.ex 2720 picture:_on_select_execute(project_debug,8192)   p_window_id: 425   p_object: OI_EDITOR   p_name:
picture.ex 2086 _tbCommand()   p_window_id: 425   p_object: OI_EDITOR   p_name:
picture.ex 2440 _ul2_picture.lbutton_down(0)   p_window_id: 174   p_object: OI_IMAGE   p_name:
« Last Edit: September 22, 2014, 03:24:03 am by tuchman »

tuchman

  • Senior Community Member
  • Posts: 136
  • Hero Points: 7
Re: B2 MAC SlickC Stack during perl debugging
« Reply #3 on: September 26, 2014, 03:58:01 am »
Just happened again on Win7-64, B5.
This time, shortly after SE went unresponsive, Windows reported it as such.

tuchman

  • Senior Community Member
  • Posts: 136
  • Hero Points: 7
Re: B2 MAC SlickC Stack during perl debugging
« Reply #4 on: September 29, 2014, 03:57:07 am »
Happened again on MacOS X, B5,

Invalid argument
mainwindow.ex 2077 mainwindow:_autorestore_from_view(16,0)   p_window_id: 16   p_object: OI_EDITOR   p_name:
mainwindow.ex 2883 debug_switch_mode(1,0)   p_window_id: 163   p_object: OI_EDITOR   p_name:
tbview.ex 305 tbDebugSwitchMode(1,0)   p_window_id: 163   p_object: OI_EDITOR   p_name:
debug.ex 444 activate_debug(perl5db,,,,30,<empty>, -socket=20  -feature-set=show_hidden=0 -feature-set=max_children=32,<empty>)   p_window_id: 163   p_object: OI_EDITOR   p_name:
debug.ex 1008 debug_begin(perl5db,,,,30,<empty>, -socket=20  -feature-set=show_hidden=0 -feature-set=max_children=32,<empty>)   p_window_id: 163   p_object: OI_EDITOR   p_name:
perlopts.ex 2124 _perl_project_command_status(3,Debug,20,perl_debug,debug,/Users/tuchman/CrashInspect/CrashInspect.app/Contents/MacOS/CrashInspect.pl,$utilsMisc,go,1,)
   p_window_id: 163
   p_object: OI_EDITOR
   p_name:
compile.ex 6627 _project_command(debug,/Users/tuchman/CrashInspect/CrashInspect.app/Contents/MacOS/CrashInspect.pl,$utilsMisc,0,1,0,0,go)   p_window_id: 163   p_object: OI_EDITOR   p_name:
compile.ex 1784 _project_command2(debug,0,1,0,0,go,/Users/tuchman/CrashInspect/CrashInspect.app/Contents/MacOS/CrashInspect.pl)   p_window_id: 163   p_object: OI_EDITOR   p_name:
compile.ex 1444 _project_debug2(0,go)   p_window_id: 163   p_object: OI_EDITOR   p_name:
debug.ex 1516 debug_go(0)   p_window_id: 163   p_object: OI_EDITOR   p_name:
compile.ex 1238 project_debug()   p_window_id: 163   p_object: OI_EDITOR   p_name:
picture.ex 2720 picture:_on_select_execute(project_debug,8192)   p_window_id: 163   p_object: OI_EDITOR   p_name:
picture.ex 2086 _tbCommand()   p_window_id: 163   p_object: OI_EDITOR   p_name:
picture.ex 2440 _ul2_picture.lbutton_down(0)   p_window_id: 154   p_object: OI_IMAGE   p_name:

Rodney

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 739
  • Hero Points: 47
Re: B2 MAC SlickC Stack during perl debugging
« Reply #5 on: September 30, 2014, 02:24:38 am »
This may have been addressed for the next build here: http://community.slickedit.com/index.php/topic,10486.0.html

Please try it out when beta 6 is available.

++rodney

tuchman

  • Senior Community Member
  • Posts: 136
  • Hero Points: 7
Re: B2 MAC SlickC Stack during perl debugging
« Reply #6 on: October 03, 2014, 05:56:57 pm »
perl debugging on Mac OS X is worse in B6 WRT B5!
When issuing "project_debug" on a "complex" perl project, SE displays "starting debugger...", or displays the attached mess for 10-20 seconds.  Thereafter, the display finally updates, and debugging more-or-less works as expected.  This happens every time, except for the time I got the slick-c stack below.

C-stack....
 Invalid argument
mainwindow.ex 2077 mainwindow:_autorestore_from_view(16,0)   p_window_id: 16   p_object: OI_EDITOR   p_name:
mainwindow.ex 2883 debug_switch_mode(1,0)   p_window_id: 184   p_object: OI_EDITOR   p_name:
tbview.ex 305 tbDebugSwitchMode(1,0)   p_window_id: 184   p_object: OI_EDITOR   p_name:
debug.ex 444 activate_debug(perl5db,,,,30,<empty>, -socket=16  -feature-set=show_hidden=0 -feature-set=max_children=32,<empty>)   p_window_id: 184   p_object: OI_EDITOR   p_name:
debug.ex 1008 debug_begin(perl5db,,,,30,<empty>, -socket=16  -feature-set=show_hidden=0 -feature-set=max_children=32,<empty>)   p_window_id: 184   p_object: OI_EDITOR   p_name:
perlopts.ex 2124 _perl_project_command_status(3,Debug,16,perl_debug,debug,/Users/tuchman/CrashInspect/CrashInspect.app/Contents/MacOS/CrashInspect.pl,prepareCoreDumpData,go,1,)
   p_window_id: 184
   p_object: OI_EDITOR
   p_name:
compile.ex 6627 _project_command(debug,/Users/tuchman/CrashInspect/CrashInspect.app/Contents/MacOS/CrashInspect.pl,prepareCoreDumpData,0,1,0,0,go)   p_window_id: 184   p_object: OI_EDITOR   p_name:
compile.ex 1784 _project_command2(debug,0,1,0,0,go,/Users/tuchman/CrashInspect/CrashInspect.app/Contents/MacOS/CrashInspect.pl)   p_window_id: 184   p_object: OI_EDITOR   p_name:
compile.ex 1444 _project_debug2(0,go)   p_window_id: 184   p_object: OI_EDITOR   p_name:
debug.ex 1516 debug_go(0)   p_window_id: 184   p_object: OI_EDITOR   p_name:
compile.ex 1238 project_debug()   p_window_id: 184   p_object: OI_EDITOR   p_name:
picture.ex 2699 picture:_on_select_execute(project_debug,8192)   p_window_id: 184   p_object: OI_EDITOR   p_name:
picture.ex 2065 _tbCommand()   p_window_id: 184   p_object: OI_EDITOR   p_name:
picture.ex 2419 _ul2_picture.lbutton_down(0)   p_window_id: 165   p_object: OI_IMAGE   p_name:

tuchman

  • Senior Community Member
  • Posts: 136
  • Hero Points: 7
Re: B2 MAC SlickC Stack during perl debugging
« Reply #7 on: October 04, 2014, 12:01:56 pm »
B6 behavior on Win7-64 is almost the same as on Mac OS X (using same large perl project). 
SE displays several partially updated windows for a few seconds, then a totally empty SE frame (Windows title shows non-responsive) for ~10 seconds until a break-point is hit. 
After issuing continue, the debugger seems to behave as expected.

Rodney

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 739
  • Hero Points: 47
Re: B2 MAC SlickC Stack during perl debugging
« Reply #8 on: October 04, 2014, 08:36:50 pm »
I was able to reproduce and fix the Slick-C stack. It will be in the next build.

++rodney