Author Topic: B4, upgrade doesn't import my macro files  (Read 2131 times)

jporkkahtc

  • Senior Community Member
  • Posts: 1948
  • Hero Points: 185
  • Text
B4, upgrade doesn't import my macro files
« on: September 12, 2014, 06:31:28 pm »

Uninstalled all previous betas, and deleted state.Installed B4.
On first run, it copied data from 18.0.1 to 19.0.0.



Copying from 18.0.1 to 19.0.0
Then 2 FileNotFound errors.


File Not Found error dialogs *really* *really* should include the path+name of the file that it was looking for.


---------------------------
SlickEdit
---------------------------
File not found
---------------------------
OK   
---------------------------
Status bar showed "Incorrect Version"


FileNotFound again, status bar shows my file "userWindow.ex"
---------------------------
SlickEdit
---------------------------
There were errors loading the following user modules (from def_macfiles).


ERROR:   C:\Users\joe_porkka\Documents\slick\19.0.0\FindIn.ex
ERROR:   C:\Users\joe_porkka\Documents\slick\19.0.0\userWindow.ex


---------------------------
OK   
---------------------------




[size=78%]Both of those files (the *.e and the *.ex versions) got copied into the 19.0.0 folder.[/size]


None of the keyboard bindings for the functions in these macro files were defined on first upgrade.


OTOH, I have another macro file, "SymHighlight.e", which also wasn't loaded, but I didn't get an error for it either.


Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2961
  • Hero Points: 440
Re: B4, upgrade doesn't import my macro files
« Reply #1 on: September 13, 2014, 12:42:48 am »
The "Incorrect version" message may be the clue to fixing this one.  We are looking into it.

Clark

  • Moderator
  • Senior Community Member
  • *
  • Posts: 5253
  • Hero Points: 432
Re: B4, upgrade doesn't import my macro files
« Reply #2 on: September 13, 2014, 01:19:48 am »
One gotcha that is not fixable is this. If you upgrade and your current directory ends up being the macros directory of v18 or a directory containing .e or .sh files which match those in v19 but are not the correct v19 versions, there will be major problems.  What ever you do, don't store your custom macros in the v18 macros directory!

I'm not sure if there is also a problem on Windows if the current directory is the v18 bin directory since the wrong macro compiler will be run (I think I fixed this years ago).

You should delete your .ex files to see if when you upgrade to v19, it actually compiles them.

skywise

  • Senior Community Member
  • Posts: 331
  • Hero Points: 10
Re: B4, upgrade doesn't import my macro files
« Reply #3 on: September 13, 2014, 04:12:18 pm »
One gotcha that is not fixable is this. If you upgrade and your current directory ends up being the macros directory of v18 or a directory containing .e or .sh files which match those in v19 but are not the correct v19 versions, there will be major problems.  What ever you do, don't store your custom macros in the v18 macros directory!

Can you clarify that?  Do you mean v18 CONFIG directory or the v18 INSTALLED directory?

Clark

  • Moderator
  • Senior Community Member
  • *
  • Posts: 5253
  • Hero Points: 432
Re: B4, upgrade doesn't import my macro files
« Reply #4 on: September 13, 2014, 04:39:57 pm »
I think the config directory is fine. The "macros" directory or any directory under there is a disaster.