Author Topic: B6 - updated formatting defaults not being used  (Read 1604 times)

jej45

  • Community Member
  • Posts: 32
  • Hero Points: 1
B6 - updated formatting defaults not being used
« on: October 10, 2014, 12:28:55 pm »
I was editing a C++ file. Noticed that the formatting defauts that I selected were not being used. Specifically, I set the tab spacing to 3, however your default value 4 was used instead. I selected brace style 2, however your default brace style of 1 was used instead. I didn't check the other customizations.

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1170
  • Hero Points: 111
Re: B6 - updated formatting defaults not being used
« Reply #1 on: October 10, 2014, 01:40:03 pm »
When did you select your settings that are being ignored?  Was it in the quick start dialog, or settings that were imported from a previous version you were using?  And if it was a previous version, what version? Or settings that you explicitly set in something like Tools -> Beautify -> Edit Profile?

And is adaptive formatting enabled?
« Last Edit: October 10, 2014, 01:54:47 pm by patrick »

jej45

  • Community Member
  • Posts: 32
  • Hero Points: 1
Re: B6 - updated formatting defaults not being used
« Reply #2 on: October 10, 2014, 02:16:05 pm »
this was an initial. It was configured during the quick start-up. I chose these default for all languages.

Under all languages->formatting
1. Indent with tabs is checked.
2. Begin/end style is style 1

Under Application Languages->ANSI-C
1. Indent wth tabs is off and the tab spaces are set to 3 (as expected)
2. Begin/end style is style 2. Adaptive is on

Under Application Languages->C++
the preview indicates that
1. Indent is set to indent with spaces and syntax indent, tab stops, and line continuation indent is set to 4
2. brace style is set to same line.

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1170
  • Hero Points: 111
Re: B6 - updated formatting defaults not being used
« Reply #3 on: October 10, 2014, 02:28:58 pm »
Hmm, I can reproduce that too.  Taking a look at it.

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1170
  • Hero Points: 111
Re: B6 - updated formatting defaults not being used
« Reply #4 on: October 10, 2014, 03:12:44 pm »
Fixed for the next drop.  Thanks for the report.