Archived Beta Discussions > Core for Kepler Beta

Eclipse crashes when editing a file in IBM HLASM mode of slickedit

(1/2) > >>

Praveen Kumar:
Opening the attached file crashes the eclipse when we try to edit the file in IBM HLASM mode of slickedit.

Even if any blank space beyond column 72 in IBM HLASM mode also crashes eclipse with the Error:"Collecting garbage". Trailing spaces option is not working in slickedit is the root cause of occurrence of spaces beyond column 72.

Which I have reported earlier:,10187.0.html

Attached .log file FYR.

Strip trailing spaces on save should be working in the current Release Candidate even with the truncation line enabled,  I will double-check on that.   I am also able to reproduce the crash with the sample, I will investigate it for a fix.

Praveen Kumar:
Hi Lee,

Thanks for your reply!!
I have tested the "Strip Trailing Mode" option of IBM hlasm mode in Eclipse Luna and confirmed that it's still not working.
Also like to let you know that "Truncation" option in SlickEdit Preference-->Language-->Assembly Language-->IBM HLASM-->General - is also not working.

Would you great if you can investigate this one as well.

I have found one more file with the same issue of eclipse hangs when this file is opens with IBM HLASM mode of slickedit.
PFA, asm file, relative log file and screenshots.

Thanks & Regards,

The fix I put in should be in the build your using, and it does work in my testing.  It should be stripping all trailing spaces, even beyond the truncation line.  To confirm, you are using is "Strip all trailing spaces", in the SlickEdit Preferences > Languages > IBM HLASM > File Options > Save Options > Strip trailing spaces.  Is this correct?

For the IBM HLASM hang, I have a hotfix specifically for Window 32-bit build.  I am attaching a hotfix that should address that.  You will need to bring up the SlickEdit command-line (bound to ESC in most emulations) and use the load-hotfix command.   You will be prompted for a zip file, point it to the attached zip file which you will need to download.  Then restart Eclipse.  Should be fixed.  If you need a 64-bit Windows version, I can provide one of those as well.

Praveen Kumar:

Thanks a lot for your hot-fix. It worked!! :-)
I retested "Strip all trailing spaces" option and it is also working good!! My apologies :-(

Could you reproduce the below issue in your system?? If yes, Is there any hot-fix available for this???

{{ "Truncation"option in SlickEdit Preference-->Language-->Assembly Language-->IBM HLASM-->General - is also not working.  }}



[0] Message Index

[#] Next page

Go to full version