Author Topic: SE Module load/unload : SE Menu Modules : Massive SE GUI failure  (Read 1293 times)


  • Senior Community Member
  • Posts: 115
  • Hero Points: -17
I am testing the current SE V19 RC2 (Release Candidate 2).

In previous posts - I tested;

---(1) SE Menu Module size limitation

---(2) SE Menu Module unload/load dialog list synchronization : via

---(2.a) SE Menu -> Macro -> List User-Loaded Macros

---(2.b) SE Menu -> Macro -> List User-Loaded Macros

---(2.c) SE Menu -> Macro -> Unload Module

In a previous post I used the following testcase.


During the test cycles of the above - I experienced a massive
failure of the SE GUI (see attached screen shots).

-------- Overview -----------------------------

The SE V19 beta seems to work OK for trivial SE modules - relative to
simple menu, toolbar and macro designs.  Trivial being both (1)
architecture and (2) cardinality of the SE code (within the custom SE

The SE V19 beta seems to break down however, even when the SE code Module
- retains a (1) trivial architecture (code complexity) - but (2) a
non-trivial increase in cardinality (relative to orders of magnitude
of the SE code artifacts).

As a hip shot - from my current SE V19 beta testing - SE V19 remains
stable - as long as the code artifact cardinality is between 1->10, 10->100. 

Once the code artifact cardinality enters the 100->1000 range, however,
many SE function operations seem to break down - especially regarding
large size SE menu modules (documented elsewhere). 

There is some strange behavior - that I get (due to large cardinality
SE modules) - that are just too complex and unrepeatable to document.

-------- Massive GUI Failure ------------------

In testing the above test cycles - (see ccv_envr_05_menus_ref_MOD_V_04.e
posted elsewhere) - I ran into a SE catastrophic failure - as show in the
attached screen shots. 

The stack errors - hopefully - will give the SE dev team some idea - of
where the SE GUI massive failure point is occurring.

In a nutshell - the My Slickedit Configuration directory - became corrupt
- and had to be wipped out and replaced.

The SE GUI failure - (as attached) - is that the GUI is blanked out -
stays that way - and can never recover.  After a while of operation cycles
- to exit/enter the SE application - it simply breaks down and dies. 

-------- Discussion ---------------------------

NOTE : It is not the SE workspace that is corrupt - because I tried to
load a different SE workspace - and the SE GUI remained broken (as

NOTE : After the massive failure - I erased the My Slickedit Configuration
directory - and reset it to a previous ZIPPED state - prior to the SE
Module load/delete/verify testing above - of large size SE menu modules. 

I have attached a screen shot of the nominal test environment - with some
custom grep toolbars - for a tag based code visibility software
engineering methodology - customization of the SE edit console
environment.  The nominal SE edit console - was screen captured - after I
reset the user configuration directory (ie; My Slickedit Configuration ). 

Note the large cardinality of menu subitems - (100->1000) - seem to be
the SE failure trigger mechanism (as in the attached screen shots).

I could not recover the stack trace text - because the failure was so
catastrophic - that the SE GUI failed to respond - and finally just died. 

-------- Future Testing pending other posts -----------------

Because I am working on other SE stuff - I did not test this extensively.

I will wait for other SE issues to be fixed, resolved - since they may
be part of the trigger mechanism for this catastrophic failure.

After they are fixed - I will try to see if this problem still exists.