Author Topic: RC3 - syntax indent broken on first launch  (Read 1712 times)

tim_k

  • Senior Community Member
  • Posts: 125
  • Hero Points: 8
  • -Tim
RC3 - syntax indent broken on first launch
« on: November 05, 2014, 08:55:40 pm »
On first launch of RC3, and opening a workspace last used with RC2, the syntax indent settings are broken and won't accept changes. In the formatting options dialog, the language specific settings show syntax indent at 2, and tabs at 2, yet the ruler shows tab stops at 4 spaces, and the tab key inserts 4 spaces. The all languages setting was blank, and setting it to 2 (in an attempt to override the language specific setting) caused a slick-C error (stack attached, dialog over settings grab attached). Noodling around with the options wouldn't fix anything, but after capturing the error and stack dump, I restarted Slickedit. Now it works as expected - tabs @ 2 spaces, tab stops on the ruler @ 2 spaces - as specified in the settings.

-Tim

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 960
  • Hero Points: 72
Re: RC3 - syntax indent broken on first launch
« Reply #1 on: November 05, 2014, 09:11:11 pm »
It almost sounds like a bad value got in the tab or syntax indent setting when doing the configuration upgrade that happens the first time a new version is run.  I'm taking a look at it now.

If you bring up the vusrdata.e file from your config directory and search for "def-language-c" (including the double quotes), what does that line look like?

tim_k

  • Senior Community Member
  • Posts: 125
  • Hero Points: 8
  • -Tim
Re: RC3 - syntax indent broken on first launch
« Reply #2 on: November 05, 2014, 09:33:26 pm »
I don't have a vusrdata.e, but the vunxdata.e has the following line:

  replace_def_data("def-language-c",'MN=C/C++,TABS=++2,MA=1 74 1,KEYTAB=c-keys,WW=1,IWT=0,ST=8,IN=2,LN=cpp,CF=1,LNL=1,TL=-1,BNDS=0 0,CAPS=0,SW=0,SOW=1,HX=0,LNF=3,ALM=0,FWRM=0');

-Tim

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 960
  • Hero Points: 72
Re: RC3 - syntax indent broken on first launch
« Reply #3 on: November 05, 2014, 09:38:01 pm »
That's the right file, different name for *nix.  Yeah, the ++2 value for tabs is not so good.  Thanks, that helps.

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 960
  • Hero Points: 72
Re: RC3 - syntax indent broken on first launch
« Reply #4 on: November 06, 2014, 04:25:07 pm »
I found a place where the extra '+' could be snuck into the tab configuration, and cleaned up some related error handling.  The fix will be in the next build, or the first hotfix.

tim_k

  • Senior Community Member
  • Posts: 125
  • Hero Points: 8
  • -Tim
Re: RC3 - syntax indent broken on first launch
« Reply #5 on: November 06, 2014, 07:11:53 pm »
Excellent.

-Tim