Author Topic: Bug: Japanese font  (Read 4325 times)

tyano

  • Community Member
  • Posts: 33
  • Hero Points: 1
Bug: Japanese font
« on: November 29, 2014, 02:44:05 am »
I want to use Japanease font in 2014.
I could use Japenase font at 2013.
In the font list of 2014, there is no popular Japanese fonts (MS Mincho or MS Gothic, this is not real name, the real name is Japanease) in the font list of option menu. The font names are shown with invalid name  like ?? ??. If I select this, the expteted Japanese font is not selected.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5953
  • Hero Points: 467
Re: Bug: Japanese font
« Reply #1 on: November 29, 2014, 03:09:14 pm »
This problem is on Unix and Mac. I assume you're on one of those platforms. This will be fixed in v19.0.1. Not sure when it will be available. We will try to get it out soon.

tyano

  • Community Member
  • Posts: 33
  • Hero Points: 1
Re: Bug: Japanese font
« Reply #2 on: December 13, 2014, 12:10:41 am »
I tried 19.0.1 RC and found that the Japanese font problem still occurs...

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5953
  • Hero Points: 467
Re: Bug: Japanese font
« Reply #3 on: December 13, 2014, 01:46:31 am »
Which font dialog are you using? I assume you are using Tools>Options>Appearance>Fonts. Please post your help about information so we can have OS information.

At the moment, I'm not sure why this wouldn't just work. Especially if it worked in SlickEdit 2013. It even should have worked in v19.0.0 since the font listing code looks like it's all done in Unicode (never in the default code page which is where other code was broken in v19.0.0).
« Last Edit: December 13, 2014, 01:51:41 am by Clark »

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5953
  • Hero Points: 467
Re: Bug: Japanese font
« Reply #4 on: December 13, 2014, 02:33:51 pm »
I created my own font with a font family name with Japanese characters in it. I was able to select it on Windows 7 and Ubuntu 14. Haven't tested on other platforms yet. I've attached a screen shot.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5953
  • Hero Points: 467
Re: Bug: Japanese font
« Reply #5 on: December 13, 2014, 03:24:20 pm »
Make sure you uncheck "Fixed Fonts Only". When it's checked, not all fonts are listed.

tyano

  • Community Member
  • Posts: 33
  • Hero Points: 1
Re: Bug: Japanese font
« Reply #6 on: December 14, 2014, 12:04:07 pm »
Following is the my environment information.
Some Japanese font names are with ? characters and not correct.
Some Japanese font names are expected name and correct.
I put captured image as attachment.

SlickEdit 2014 (v19.0.0.14 64-bit)

Serial number: *******
Licensed number of users: Single user
License file: C:\ProgramData\slickedit\19\slickedit.lic

Build Date: November 06, 2014
Emulation: SlickEdit (text mode edition)

OS: Windows 8 x64
OS Version: 6.02.9200 
Memory: 45% Load, 3661MB/8071MB Physical, 4037MB/9351MB Page File, 299MB/134217727MB Virtual
Shell Info: C:\WINDOWS\system32\cmd.exe /q
Screen Size: 1920 x 1080

Project Type: No project open
Language: No file open
Encoding: No file open

Installation Directory: C:\Program Files\SlickEditV19.0.0 x64\ (non-removable drive,NTFS,256953MB free)
Configuration Directory: C:\Users\tyano\Documents\My SlickEdit Config\19.0.0\ (non-removable drive,NTFS,25695

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5953
  • Hero Points: 467
Re: Bug: Japanese font
« Reply #7 on: December 14, 2014, 12:35:53 pm »
Please post an Xml Utf-8 text file (or just Utf-8 text file) with a couple corrected font names. I'm only interested in the font name text which doesn't show correctly. I will try to create a font with that name and see what happens.

Do the fonts with question marks (?) show up correctly in the notepad.exe font list (without question marks)? If they don't show up correctly in other applications, then I will need to try something else.
« Last Edit: December 14, 2014, 07:22:12 pm by Clark »

tyano

  • Community Member
  • Posts: 33
  • Hero Points: 1
Re: Bug: Japanese font
« Reply #8 on: December 15, 2014, 10:01:28 pm »
Okay
I will prepare the list of the Japanease font names in UTF-8 text.

tyano

  • Community Member
  • Posts: 33
  • Hero Points: 1
Re: Bug: Japanese font
« Reply #9 on: December 16, 2014, 12:27:47 pm »
The attachement is the font display names at 18 and 19 comparison. There are only font names with DBCS characters.
I guess:
The names including single byte katakana characters are BAD.
The names include double byte alphanet characters are BAD.
The other names include double byte characters are GOOD.

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1583
  • Hero Points: 140
Re: Bug: Japanese font
« Reply #10 on: December 16, 2014, 02:12:28 pm »
Thanks for the comprehensive list, it narrows down what I need to look at today.