Author Topic: Reverting back to V18.  (Read 2490 times)

lambertia

  • Senior Community Member
  • Posts: 382
  • Hero Points: 14
  • I have nothing sufficiently witty to say.
Reverting back to V18.
« on: November 10, 2014, 01:58:38 am »
 :(

All,

V19 and gdb are simply not working for me. I cannot even open a core file without SE giving timeout errors. I reported this earlier in the forums and have yet to hear from you.

I am now reverting back to V18 so that I can work.

Help me help you. What information do you need.

Cheers,
--
Sad Greg.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4587
  • Hero Points: 357
Re: Reverting back to V18.
« Reply #1 on: November 10, 2014, 02:07:28 pm »
On our todo list. Sorry we haven't gotten to this yet.

lambertia

  • Senior Community Member
  • Posts: 382
  • Hero Points: 14
  • I have nothing sufficiently witty to say.
Re: Reverting back to V18.
« Reply #2 on: November 10, 2014, 08:55:29 pm »
Great! As long as its on the list I'm happy :)

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2555
  • Hero Points: 380
Re: Reverting back to V18.
« Reply #3 on: November 14, 2014, 07:35:14 pm »
Greg,

Remind me, what platform are you working on?  Have you tried the GDB that is shipped with SlickEdit rather than /usr/bin/gdb?  Could you turn on def_debug_logging and post the logging results found in <config>/logs/debug.log when you try to open a core file.

lambertia

  • Senior Community Member
  • Posts: 382
  • Hero Points: 14
  • I have nothing sufficiently witty to say.
Re: Reverting back to V18.
« Reply #4 on: November 17, 2014, 06:28:51 am »
Hi!

I am using the SE version. I'll enable the logging and give it a go tomorrow. Thanks!

--
SlickEdit 2014 (v19.0.0.14 32-bit)

Serial number: FE10194_BETA
License type: Beta License
License expiration: 2014-12-11 09:06:00
License file: /opt/slickedit-19.0.0.14/bin/slickedit.lic

Build Date: November 06, 2014
Emulation: Brief

OS: Linux
OS Version: Ubuntu 10.04.4 LTS
Kernel Level: 3.13.0-37-generic
Build Version: #64-Ubuntu SMP Mon Sep 22 21:28:38 UTC 2014
Processor Architecture: i686

X Server Vendor: The X.Org Foundation
Memory: 98% Load, 14648MB/14894MB Virtual
Shell Info: /opt/slickedit-19.0.0.14/bin/secsh -i
Screen Size: 1920 x 1080, 1920 x 1080

Project Type: Python
Language: .cpp (C/C++)
Encoding: Automatic

Installation Directory: /opt/slickedit-19.0.0.14/
Configuration Directory: /space/gbarron/work/mo-r3.4.2/se/sc/19.0.0/


lambertia

  • Senior Community Member
  • Posts: 382
  • Hero Points: 14
  • I have nothing sufficiently witty to say.
Re: Reverting back to V18.
« Reply #5 on: November 19, 2014, 04:42:04 am »
Hi!

I've attached three log files. The first is the working version with V18.

The second two (I think you are outputting to %sdebug.log by error) are from V19.

« Last Edit: November 19, 2014, 04:49:59 am by lambertia »

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2555
  • Hero Points: 380
Re: Reverting back to V18.
« Reply #6 on: November 19, 2014, 09:38:42 pm »
Thanks for pointing out that it was writing some messages to the wrong log.  That will be fixed in the next version.

Have you tried configuring SlickEdit to use the GDB executable that came with version 18?  It appears, based on your logging info, to be the case that the newer GDB does not send a reply to the "-target-select core " command.  I'm going to put a workaround for that nonsense into the next release.

lambertia

  • Senior Community Member
  • Posts: 382
  • Hero Points: 14
  • I have nothing sufficiently witty to say.
Re: Reverting back to V18.
« Reply #7 on: November 19, 2014, 10:30:10 pm »
That is a great idea!