Author Topic: SlickEdit 19: How to disable multiple cursors?  (Read 2587 times)

SlickUser56

  • Junior Community Member
  • Posts: 6
  • Hero Points: 0
SlickEdit 19: How to disable multiple cursors?
« on: December 15, 2014, 04:00:20 pm »
I am constantly activating multiple cursors by accident. How do you disable this feature.

Thanks....

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3514
  • Hero Points: 470
Re: SlickEdit 19: How to disable multiple cursors?
« Reply #1 on: December 15, 2014, 05:28:26 pm »
This is a common problem if you work on a laptop with a touchpad with the "tap to click" option enabled.  One option is to disable tap to click, but most people find it very useful under normal circumstances.

From within SlickEdit, the best way to disable multiple cursors is to do the following.  Go to Tools > Options > Keyboard and Mouse > Key Bindings... and search for the command mou_click_copy.  It will be bound to Ctrl+LButtonDn.  Remove the key binding.  You may also want to remove the binding for mou_click_copy_block, but that will be less likely to cause problems for you.

You could also bind that command to another key sequence you would be less likely to type by accident, like Ctrl+Shift+Plus (to add a cursor at the location under the mouse).

SlickUser56

  • Junior Community Member
  • Posts: 6
  • Hero Points: 0
Re: SlickEdit 19: How to disable multiple cursors?
« Reply #2 on: December 15, 2014, 06:28:40 pm »
Thanks for the quick reply.  I am using a laptop so this is a big problem.  Given how common this issue is can you add an option to disable multiple cursors within SlickEdit? I much rather turn the feature on or off depending on my needs than changing my laptop settings or SlickEdit key bindings.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 6203
  • Hero Points: 481
Re: SlickEdit 19: How to disable multiple cursors?
« Reply #3 on: December 15, 2014, 07:35:07 pm »
Unbind ctrl+click