Author Topic: Installation fails for lack of (uninstalled lib?) file  (Read 1930 times)

symon

  • New Community Member
  • Posts: 1
  • Hero Points: 0
Installation fails for lack of (uninstalled lib?) file
« on: December 18, 2014, 11:03:32 pm »
CentOS6 VMWare VM
Eclipse IDE for C/C++ Developers
Version: Indigo Service Release 2
Build id: 20120216-1857

Installing from Eclipse. Tried both from site and from zip file. Tried as user. Long install process ends with error message:

An error occurred while installing the items
session context was:(profile=epp.package.cpp, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]com.slickedit.linux64.libs 4.3.2, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.ChmodAction).
The action chmod failed - file /usr/local/eclipse/plugins/com.slickedit.linux64.libs_4.3.2/slickedit does not exist.

Tried as root. Long install process seemed to work but now my Ecllipse is broken for both user and root. Refers to error in log file.

.log file has a lot of error messages like this:

!ENTRY org.eclipse.osgi 4 0 2014-12-18 17:51:59.883
!MESSAGE Application error
!STACK 1
java.lang.UnsatisfiedLinkError: com.slickedit.eclipse.SlickEditSystem.getAlertGroupVisible(I)I
   at com.slickedit.eclipse.SlickEditSystem.getAlertGroupVisible(Native Method)
   at com.slickedit.swt.StatusIcon.createControl(StatusIcon.java:55)
...



Lee

  • Moderator
  • Senior Community Member
  • *
  • Posts: 1092
  • Hero Points: 94
Re: Installation fails for lack of (uninstalled lib?) file
« Reply #1 on: December 19, 2014, 02:16:50 pm »
SlickEdit Core 4.3.2 is a release for Kepler and later releases.  For Eclipse Indigo release, you will need to use the Core 3.7, it can still be found on the update site: https://customer.slickedit.com/update/secore/indigo


paladin

  • Community Member
  • Posts: 10
  • Hero Points: 0
Re: Installation fails for lack of (uninstalled lib?) file
« Reply #2 on: March 06, 2015, 05:12:37 pm »
I'm having a similar issue loading eclipse core on Centos 7 x64 with Kepler. I've tried the installer instruction and get:
An error occurred while installing the items
session context was:(profile=epp.package.cpp, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]com.slickedit.linux64.libs 4.3.2, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.ChmodAction).
The action chmod failed - file /opt/eclipse/plugins/com.slickedit.linux64.libs_4.3.2/slickedit does not exist.
I also downloaded and install the zip package to /opt/eclipse - no joy...  I noticed that there is a not that Linux requires 32bit Java?   Does the system support x64 Linux?