Author Topic: UTF-8 and vertical select results in jagged select block  (Read 2088 times)

tmb

  • Community Member
  • Posts: 13
  • Hero Points: 0
UTF-8 and vertical select results in jagged select block
« on: December 22, 2014, 01:17:58 AM »
Hi all,

I've scourged the forum to try to find some mention of this problem but found nothing. Maybe i'm using the wrong search terms.

Anyway, i don't know if i'm doing something wrong here but i cannot get the vertical selection to work properly with national characters in an UTF-8 format file. I have attached an image that shows how it looks on my screen. The cursor was placed on the double quote on the first line and then moved down. As can be seen the selection gets really messed up. This is caused by the French national characters in the text. I tried reopening the file in Auto Unicode but the effect is still the same. I cannot switch from UTF-8 format because the file can contain virtually national character from any language. This kind of ruins the vertical selection completely.

Is there a setting or something i need to do to get this to work? Any help would be appreciated.

I'm using SlickEdit 2013 (v18.0.1.2 64-bit) on Windows 7.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 6850
  • Hero Points: 526
Re: UTF-8 and vertical select results in jagged select block
« Reply #1 on: December 22, 2014, 02:39:05 AM »
column selections are not supported by proportional fonts yet and unicode support requires proportional fonts.

The current plan is to support proportional font column selections in v20.

tmb

  • Community Member
  • Posts: 13
  • Hero Points: 0
Re: UTF-8 and vertical select results in jagged select block
« Reply #2 on: December 22, 2014, 06:45:30 AM »
Ok. I will do this in Visual Studio then and be looking forward to v20 :D

Thanks for the reply!