Author Topic: Menus stop dropping down  (Read 4496 times)

mwb1100

  • Senior Community Member
  • Posts: 151
  • Hero Points: 13
Menus stop dropping down
« on: February 07, 2015, 01:30:41 am »
I'm running into an intermittent (but frequent enough) problem with SlickEdit 2014 (v19.0.1.1 64-bit) running on Ubuntu 12.04.1 LTS.

Sometimes some menus won't drop down, even though the other menus will (sometime none will).  It seems like minimizing SE triggers the behavior.  Restarting SE will fix it.

When the menus are in this mode, the operations still work by using the keys (for example, Alt-FO will bring up the Open File dialog). Also the 'help' text that in the bottom status bar still displays. For example, when I click on the File menu nothing drops down, but the word "File" on the menu bar gets highlighted and the status bar at the bottom says "Displays file menu".

Any suggestions on how to troubleshoot this?

mwb1100

  • Senior Community Member
  • Posts: 151
  • Hero Points: 13
Re: Menus stop dropping down
« Reply #1 on: February 12, 2015, 06:22:40 pm »
Bump...  and one more piece of information - starting vs with a clean config (using the -sc option to point to a own directory) still has the problem.

mwb1100

  • Senior Community Member
  • Posts: 151
  • Hero Points: 13
Re: Menus stop dropping down
« Reply #2 on: February 12, 2015, 11:42:43 pm »
And installing the hotfix_se1901_2_cumulative.zip that just came out today doesn't help.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 6437
  • Hero Points: 502
Re: Menus stop dropping down
« Reply #3 on: February 12, 2015, 11:56:51 pm »
I haven't heard of this particular Ubuntu native menu bar problem. Doubt it has anything to do with your SlickEdit configuration. There must be something different with your Ubuntu installation but I have no idea what. If the native menu bar is too annoying you can disable it and use the more reliable menu bar within the application window.

set the QT_X11_NO_NATIVE_MENUBAR environment variable to 1 and launch SlickEdit. Since "vs" is a script, you can set it there if you want.

mwb1100

  • Senior Community Member
  • Posts: 151
  • Hero Points: 13
Re: Menus stop dropping down
« Reply #4 on: February 13, 2015, 02:35:35 am »
That didn't help, but it reminded me that I might have a non-standard Unity setup.  If Ubuntu 12.04 is supposed to have the 'global' menu bar that all apps share, then I've done something to disable that - all apps on my Ubuntu box have the menu in the app window. I don't have any notes on what I might have done to get the "App local" menus, and the bit of Googling I just did to try to restore Ubuntu to have global menus didn't result in me being able to get them back.

So if this problem is due to my monkeying around with Ubuntu's standard menu bar, then I think there's nothing to be done by you. But if you or anyone has any ideas, I'm still up for trying things.

I think I may try ditching the stock Ubuntu for Linux Mint.  I haven't been a fan of Unity anyway - for example, the global menu bar.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 6437
  • Hero Points: 502
Re: Menus stop dropping down
« Reply #5 on: February 13, 2015, 02:23:14 pm »
Ah..There's a know bug with using the setting for putting the menu bar in the window title bar. I didn't think Ubuntu 12.x supported that. You will definitely need to set the environment variable I mentioned to 1 or reconfigure your Ubuntu to turn that off. Once you display a SlickEdit modal dialog, the menu bar becomes dead. Easy to reproduce if you know the steps.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 6437
  • Hero Points: 502
Re: Menus stop dropping down
« Reply #6 on: February 13, 2015, 02:26:54 pm »
Overall, I like Ubuntu but I'm not happy with some of the Ubuntu 14 (12 wasn't a problem) window manager changes. With Ubuntu 14, if you accidentally press Alt and lift your finger focus is taken away from your app (in this case SlickEdit). There doesn't seem to be a way to turn this off. I accidentally do this way to much. Many other Window manager keys are configurable but not this one which is the only one which really matters to me.

mwb1100

  • Senior Community Member
  • Posts: 151
  • Hero Points: 13
Re: Menus stop dropping down
« Reply #7 on: February 14, 2015, 01:03:38 am »
I have moved this dev environment to Linux Mint 17.1 Rebecca x64 (with the MATE desktop environment in case that matters), and SE 2014 (v19.0.1.1 64-bit) doesn't have this problem with the menus.

I'm pretty sure that something I did to the default Ubuntu Unity environment is responsible for the problem on the system where I had the problem.  So I'm going to drop troubleshooting this issue unless you have something specific you want me to try (I still have the problem environment available for now).   Keep in mind that exporting QT_X11_NO_NATIVE_MENUBAR=1 did not change any behavior for me.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 6437
  • Hero Points: 502
Re: Menus stop dropping down
« Reply #8 on: February 15, 2015, 01:31:50 pm »
I tried setting QT_X11_NO_NATIVE_MENUBAR to 1 on Ubuntu 14 with the "show the menus for a window" option set to "In the windows's title bar" and it worked (disabled menu being displayed in window title bar- got non-native Qt menu bar in window). I would expect this to always work.