Author Topic: No Line Wrapping ... Please  (Read 5372 times)

Thom Little

  • Community Member
  • Posts: 83
  • Hero Points: 2
No Line Wrapping ... Please
« on: March 19, 2007, 07:37:32 pm »
The SlickEdit 2007 released version.  Editing ASP 3 files.  It just decides that it wants to wrap the lines at column 80 and prevents me from doing anything else.

This of course happens only on when there is a customer anxous for the change to be made so I switch to the previosu version of SlickEdit, reload all the files, and then make the changes.

I don't have any wrapping enabled in either version.  The old version always works correctly .  2007 sometimes works correctly and sometimwes does not.

... Thom

Thom Little

  • Community Member
  • Posts: 83
  • Hero Points: 2
Re: No Line Wrapping ... Please
« Reply #1 on: March 20, 2007, 11:17:47 am »
When the format of the data in the file is important, this "feature" prevents me from using SlickEdit 2007.

My GUESS is that this and a few other "features" are caused by my upgrading from the previous version of SlickEdit instead of doing a "cold install".

What is the recommended procedure for blowing away ALL SlickEdit 2007 saved parameters and startting with the defaults?

... Thom

hs2

  • Senior Community Member
  • Posts: 2736
  • Hero Points: 288
Re: No Line Wrapping ... Please
« Reply #2 on: March 20, 2007, 11:32:59 am »
You could try vs.exe +new -sc <empty (config) dir> to check if it gets better.
But you should 1st check the File Extension setup for 'asp'.
There is a (new) 'HTML Options' button at the bottom of the dialog, which brings you to 'HTML Formatting Options', which has a 'Tag Options button', which finally let you adjust 'Content wrap' settings...
Maybe your issue is related that.

HS2

David_O

  • Senior Community Member
  • Posts: 152
  • Hero Points: 8
Re: No Line Wrapping ... Please
« Reply #3 on: March 20, 2007, 01:01:00 pm »
'asp' is not truly a separate document mode.  It refers to 'html' so follows all the settings that you have set (or came as defaults with 2007) for the 'html' document mode.  If you do not want wrapping or tag layout for .asp files, simply turn it off for html.  Do this by selecting Document -> XML/HTML Formatting and making sure Enable HTML Formatting is not checked.

Or you can use the feature to adjust the wrap to work as you like.  You can use the method HS2 suggests, or get to that formatting schemes configuration dialog more directly through the Tools -> Options -> XML/HTML Formatting menu.  Additionally, you can set which formatting scheme to use for your file through the Document -> XML/HTML Formatting -> Current Document Options menu (or by right clicking in the edit buffer and picking Select XML/HTML Formatting Options on the context menu).  This second dialog also has a button that will bring up the formatting scheme configuration dialog.

Thom Little

  • Community Member
  • Posts: 83
  • Hero Points: 2
Re: No Line Wrapping ... Please
« Reply #4 on: March 20, 2007, 01:41:00 pm »
The accursed wrapping is disabled!

Your first suggestion seems to have corrected my problem.  The drop down is a little unusual.  It had six entries and they were all checked.  When I unchecked "Enable HTML Formatting" it unchecked the last three entries.

This one was nailing me because I had customers who wanted immediate changes and I could not get the blessed thing to not wrap my text.

I will dig into the changes when the pressure is a little off.

Thanks to both of you.

... Thom


Lisa

  • Senior Community Member
  • Posts: 238
  • Hero Points: 23
  • User-friendly geek-speak translator extraordinaire
Re: No Line Wrapping ... Please
« Reply #5 on: March 20, 2007, 02:05:40 pm »
The accursed wrapping is disabled!

Your first suggestion seems to have corrected my problem.  The drop down is a little unusual.  It had six entries and they were all checked.  When I unchecked "Enable HTML Formatting" it unchecked the last three entries.


Thom - I laughed out loud because I had similar sentiments at times when working on the documentation. ;D  When you get a chance, please do check out the Help on xml/html formatting - we've tried to explain clearly how the enabling options work (the six entries you mentioned) and all the other settings. The feature seems a bit complicated but that's because it's so configurable. If you spend a bit of time learning how it works and setting it up, you won't have to think about it again. After using it for awhile, I would hate to work without it!

Thom Little

  • Community Member
  • Posts: 83
  • Hero Points: 2
Re: No Line Wrapping ... Please
« Reply #6 on: March 20, 2007, 02:30:27 pm »
It is probably a GREAT new facility.  It is unfortunate that v12 wasn't released with it turned off so we could discover its power by turning it on.

... Thom

jkwuc89

  • Senior Community Member
  • Posts: 199
  • Hero Points: 6
Re: No Line Wrapping ... Please
« Reply #7 on: March 21, 2007, 01:25:02 pm »
After being surprised by how SlickEdit 2007 started to automatically wrap lines inside my PHP files due to the new XML/HTML wrapping feature, I immediately turned off this new feature.  When I get some time, I may experiment with this new feature later.