Author Topic: Multi Monitor bug? (WinXP, 11.0.2)  (Read 7712 times)

BrianMeinke

  • Community Member
  • Posts: 5
  • Hero Points: 0
Multi Monitor bug? (WinXP, 11.0.2)
« on: February 12, 2007, 02:49:54 pm »
I have a dual monitor configuration (laptop + external monitor). The laptop display is configured as the primary screen with a resolution of 1920X1200 [screen coord's (0,0)->(1920,1200)]; the external monitor is the secondary display with a resolution of 1600x1200 [screen coord's (0,-1200)->(1600,0) i.e. the secondary monitor is positioned "above" my laptop screen]. When I run SlickEdit on the secondary monitor, the tag pop-up window does not show itself (or at least it only shows itself as a 1 pixel line that is completely unusable). When I run slick edit from the primary screen, the tag pop-up window shows up just fine. I have installed the Cumulative hot-fix package. I have tried deleting my vslick.sta file to no avail. I have tried using the "-summ" option (specified as an argument to the slick edit shortcut from the start menu AND from within the VSLICK.INI file) to no avail. Any help would be greatly appreciated.

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2627
  • Hero Points: 405
Re: Multi Monitor bug? (WinXP, 11.0.2)
« Reply #1 on: February 16, 2007, 11:35:56 pm »
Are you using any multi-monitor utilities (nView desktop manager, UltraMon, MultiMon, or something else)?  Try turning it off and see if things work properly.  You generally do not need the -summ option on Windows, since the monitors can be identified for us by the OS.  The -summ option was put in more for Linux and Mac, which virtualize your monitors into one huge screen space.

Jealous note: where'd you get a laptop with a 1920x1200 display?

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2627
  • Hero Points: 405
Re: Multi Monitor bug? (WinXP, 11.0.2)
« Reply #2 on: February 16, 2007, 11:41:06 pm »
Quick update:  Just noticed the part about the secondary monitor being ABOVE the primary and was able to reproduce this.  Thanks for letting us know about this problem.  I will file a defect and let the appropriate developer know about the problem.

jbhurst

  • Senior Community Member
  • Posts: 405
  • Hero Points: 33
Re: Multi Monitor bug? (WinXP, 11.0.2)
« Reply #3 on: February 17, 2007, 12:36:57 am »
@Dennis

I have an IBM/Lenovo Z61p that I got late last year. It has a 1920x1200 display and it's awesome as a development machine. My last two laptops (also IBM) had 1600x1200 displays. Some people find the text too small, but I have strong glasses. :-)

At my home I have a 23" LCD 1920x1200 display too, which I sometimes use as a secondary display for my laptop.

In my opinion the IBM laptops have the best keyboards and screens by far of any I've used.

Regards

John Hurst

BrianMeinke

  • Community Member
  • Posts: 5
  • Hero Points: 0
Re: Multi Monitor bug? (WinXP, 11.0.2)
« Reply #4 on: February 19, 2007, 03:27:12 pm »
The laptop is an HP/Compaq nw8240 that was "forced" upon me at work along with a 20" external LCD monitor. Fairly nice computer, but the laptop screen is a little dim compared to other Dell/IBM laptops I've had in the past.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4652
  • Hero Points: 373
Re: Multi Monitor bug? (WinXP, 11.0.2)
« Reply #5 on: February 19, 2007, 07:29:00 pm »
I have fixed this problem.  The command line auto-complete feature also has this problem and I will see if I can fix this as well.

BrianMeinke

  • Community Member
  • Posts: 5
  • Hero Points: 0
Re: Multi Monitor bug? (WinXP, 11.0.2)
« Reply #6 on: February 23, 2007, 04:32:31 pm »
Great! Will this fix be released? If so, do you know the time frame of the release?

BrianMeinke

  • Community Member
  • Posts: 5
  • Hero Points: 0
Re: Multi Monitor bug? (WinXP, 11.0.2)
« Reply #7 on: March 19, 2007, 07:42:27 pm »
Well it's been almost a month now. Any updates?

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4652
  • Hero Points: 373
Re: Multi Monitor bug? (WinXP, 11.0.2)
« Reply #8 on: March 21, 2007, 01:57:31 pm »
Have you tried V12?

BrianMeinke

  • Community Member
  • Posts: 5
  • Hero Points: 0
Re: Multi Monitor bug? (WinXP, 11.0.2)
« Reply #9 on: March 21, 2007, 03:30:09 pm »
No. Do I need to upgrade in order to get the fix/patch?

Lisa

  • Senior Community Member
  • Posts: 238
  • Hero Points: 23
  • User-friendly geek-speak translator extraordinaire
Re: Multi Monitor bug? (WinXP, 11.0.2)
« Reply #10 on: March 21, 2007, 04:21:23 pm »
No. Do I need to upgrade in order to get the fix/patch?

Brian - when Clark made the post that it had been "fixed", he meant that he had fixed it for SlickEdit 2007, because we were in the midst of beta testing the new release at that time. Now SlickEdit 2007 has been officially released, so the fix is actually in that version. I don't believe there are any special patches or fixes to address this particular issue for v11.

You can try the new version for free or if you are on Maintenance & Support, you qualify for a specially priced free upgrade. See our Web site for full details. Here is an interesting thread about the benefits of Maintenance & Support:
http://community.slickedit.com/index.php?topic=1265.0

Best wishes,
Lisa
« Last Edit: March 21, 2007, 04:35:16 pm by Lisa »

Phil Barila

  • Senior Community Member
  • Posts: 742
  • Hero Points: 61
Re: Multi Monitor bug? (WinXP, 11.0.2)
« Reply #11 on: March 21, 2007, 04:31:04 pm »
If Brian is on Maintenance and Support, that "specially priced" should be == 0.   :D

Lisa

  • Senior Community Member
  • Posts: 238
  • Hero Points: 23
  • User-friendly geek-speak translator extraordinaire
Re: Multi Monitor bug? (WinXP, 11.0.2)
« Reply #12 on: March 21, 2007, 04:33:02 pm »
Oops! :-[ Thanks for the correction Phil!