Author Topic: "Error Saving settings..." when changing the C++ comment string  (Read 729 times)

rgloden

  • Senior Community Member
  • Posts: 133
  • Hero Points: 3
When I attempt to change the C++ comment in the Options Dialogue to "// |" (I know, strange but that's the code I've been given) and then save the change, I get:

   Error saving settings for language .C/C++

SE 19.0.0.14 64-Bit Windows 7 x64

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 805
  • Hero Points: 45
Re: "Error Saving settings..." when changing the C++ comment string
« Reply #1 on: May 05, 2015, 06:06:14 pm »
Even going back to 19.0.0, I haven't been able to get this to happen.  If you change some other setting in that panel, do you get the same error? 

rgloden

  • Senior Community Member
  • Posts: 133
  • Hero Points: 3
Re: "Error Saving settings..." when changing the C++ comment string
« Reply #2 on: May 07, 2015, 02:28:08 am »
To answer your question, it was only the items in the left column of the "C/C++ Comments" Options screen.  Changing other options, e.g. Extend leading border, Split line comments, etc. updated fine.

Then I noticed that my Backups and AutoSaves had not been working for over a month (it looked like they turned themselves off?).  Wow that is a little scary ... and at shutdown SE was complaining about not being able to copy some file -- maybe vusrdef.e? -- which I had been blissfully ignoring.

In any case, after playing around with Backups and AutoSaves, the problem mentioned above solved itself and SE is cleanly shutting down again ... and Backups/AutoSaves are working again.  So maybe this was self-inflicted by ignoring the warning at shutdown?

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 805
  • Hero Points: 45
Re: "Error Saving settings..." when changing the C++ comment string
« Reply #3 on: May 07, 2015, 01:23:04 pm »
Very strange.   Normally, I'd not expect that unless the config was on a full/almost full volume.  I think I also had something similar once when a volume was silently marked read-only because of disk errors.   Did you have to change anything substantial in the Auto Save/Backup settings, or just fiddling with them and saving back the same values do it?

rgloden

  • Senior Community Member
  • Posts: 133
  • Hero Points: 3
Re: "Error Saving settings..." when changing the C++ comment string
« Reply #4 on: May 08, 2015, 01:58:34 am »
Truthfully I'm not sure exactly what I fiddled with but I'm sure that I toggled the "Create backup history on save".