Author Topic: SlickEdit Pro 2014 (v19.0.2.5) Mac: prev-buffer issue  (Read 2743 times)

ExtremeXS

  • Senior Community Member
  • Posts: 108
  • Hero Points: 6
SlickEdit Pro 2014 (v19.0.2.5) Mac: prev-buffer issue
« on: July 22, 2015, 12:42:29 pm »
Hi,

I tend to use Ctrl-N and Ctrl-P to navigate my open documents.  I have noticed since moving to V19 that whilst next-buffer behaves the same as previous versions - sequentially stepping through each buffer (in this case each has its own window).

prev-buffer however only steps back a single step and than toggles back to the buffer where it originated from.  In effect wherever I am in the buffer list, previous only steps back once, then forward, then back, then forward - only switching between the current and previous buffer in a cycle.

Not had a chance to repro this on a PC system a yet, and looks like the deeper code for this is within the editor code not the macros.

I am away I can use window/tab commands to achieve similar goals, and all the other prev/next commands I have tried to not exhibit the issue that prev-buffer has.

Cheers,
Mark

rajkej

  • Senior Community Member
  • Posts: 281
  • Hero Points: 12
Re: SlickEdit Pro 2014 (v19.0.2.5) Mac: prev-buffer issue
« Reply #1 on: July 22, 2015, 02:14:41 pm »
I don't have this issue using CUA emulation, Editor Windows->Files per window=Multiple files share windows, Smart next window stype = smart next window.

I wonder if some of your settings there differ and are causing the behavior you are seeing?

ExtremeXS

  • Senior Community Member
  • Posts: 108
  • Hero Points: 6
Re: SlickEdit Pro 2014 (v19.0.2.5) Mac: prev-buffer issue
« Reply #2 on: July 22, 2015, 03:31:03 pm »
Hi,

I had already tried the smart window modes, they do not appear to impact the issue.

I use the following setting:

Editor Windows->Files Per Window == One File Per Window


On my system, this issue does not occur when that option is set to: "Multiple files share window".

So it seems likely to only be affecting "One file per window" mode.

Thanks,
Mark

Tim Kemp

  • Senior Community Member
  • Posts: 533
  • Hero Points: 90
Re: SlickEdit Pro 2014 (v19.0.2.5) Mac: prev-buffer issue
« Reply #3 on: July 23, 2015, 02:48:14 pm »
On Windows I see the same behavior: One file per window causes the toggling back and forth, Multiple files share window goes through all the files, but in a single tab.

rajkej

  • Senior Community Member
  • Posts: 281
  • Hero Points: 12
Re: SlickEdit Pro 2014 (v19.0.2.5) Mac: prev-buffer issue
« Reply #4 on: July 23, 2015, 02:51:21 pm »
Since this is a public support forum and I don't know if the developers watch every thread, I'd suggest that the original poster, ExtremeXS, file a bug with SE and reference this thread. In my experience you'll get a much better response that way.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4690
  • Hero Points: 378
Re: SlickEdit Pro 2014 (v19.0.2.5) Mac: prev-buffer issue
« Reply #5 on: July 23, 2015, 04:07:57 pm »
No need to file a bug. One file per is supposed to change this. The fix is to use multiple files share windows.

You could try using the file tabs tool window. It works well with multiple files share window.
« Last Edit: July 23, 2015, 04:40:48 pm by Clark »

ExtremeXS

  • Senior Community Member
  • Posts: 108
  • Hero Points: 6
Re: SlickEdit Pro 2014 (v19.0.2.5) Mac: prev-buffer issue
« Reply #6 on: July 24, 2015, 01:30:32 pm »
Thanks for the responses,

Just to confirm you are saying that with 'One file per window' this is now expected behaviour even though it's not been the behaviour or 'prev-buffer' on any versions since at least V14 or so when I started using the editor?

It's not a problem for as as I will switch to one of the newer ctrl-tab type mappings, just confirming that those '-buffer' commands are only really relevant in 'Multiple files share window' mode.

Thanks,
Mark

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4690
  • Hero Points: 378
Re: SlickEdit Pro 2014 (v19.0.2.5) Mac: prev-buffer issue
« Reply #7 on: July 24, 2015, 03:22:12 pm »
The next and prev buffer commands have always been the same. They have always worked oddly in one file per window mode.

When in one file per window mode, it is expected that a some kind of next/prev window will be used. It's always been that way.

If you used to use multiple files share window, changing to one file per window mode is a radical change like changing emulation.

ExtremeXS

  • Senior Community Member
  • Posts: 108
  • Hero Points: 6
Re: SlickEdit Pro 2014 (v19.0.2.5) Mac: prev-buffer issue
« Reply #8 on: July 24, 2015, 05:26:29 pm »
Since it was added, I have always used 'One file per window' mode.  The multiple per window is too drastic a change for me as you point out.

It's interesting that the have always behaved oddly in this mode, as I have been using them without issue until recently.  I will actually sanity check myself as I am sure I still have older versions on the PC.

Anyway remapped by keys to use next/prev-window as this restores the behaviour in a way that is at least syntacticly more consistent with the action being performed, where as the buffer commands are clearly happier dealing with switching the component it was designed for in the current window.

Cheers,
Mark

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4690
  • Hero Points: 378
Re: SlickEdit Pro 2014 (v19.0.2.5) Mac: prev-buffer issue
« Reply #9 on: July 24, 2015, 05:39:14 pm »
Are you using Mac or CUA emulation?

ExtremeXS

  • Senior Community Member
  • Posts: 108
  • Hero Points: 6
Re: SlickEdit Pro 2014 (v19.0.2.5) Mac: prev-buffer issue
« Reply #10 on: July 25, 2015, 08:34:36 am »
Hey Clark,

I am using CUA emulation on both Mac an PC.

I found an older V18 on my PC and it's behaviour works as expected with next/prev buffers stepping through all buffers (connected independently to separate windows).

I am not sure when this changed in V19, as the project I was using with 19.0.1 was very much single source files - so I did not do any buffer switching.

Cheers,
Mark

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4690
  • Hero Points: 378
Re: SlickEdit Pro 2014 (v19.0.2.5) Mac: prev-buffer issue
« Reply #11 on: July 25, 2015, 02:26:53 pm »
With a bit of testing I was able to reproduce this problem. It is supposed traverse all buffers but which window can be weird (that's normal). I'll need to test it more. If I start SlickEdit without a project open, it doesn't happen. If I remove the +BP switch from def_load_options, it doesn't happen but I shouldn't have to do that. Thats all I've found so far.

I'll keep you posted.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4690
  • Hero Points: 378
Re: SlickEdit Pro 2014 (v19.0.2.5) Mac: prev-buffer issue
« Reply #12 on: August 18, 2015, 08:00:49 am »
This will be fixed in v20. Thanks for the post

ExtremeXS

  • Senior Community Member
  • Posts: 108
  • Hero Points: 6
Re: SlickEdit Pro 2014 (v19.0.2.5) Mac: prev-buffer issue
« Reply #13 on: August 18, 2015, 12:16:58 pm »
Thanks for the update on a fix.

Cheers,
Mark

Tim Kemp

  • Senior Community Member
  • Posts: 533
  • Hero Points: 90
Re: SlickEdit Pro 2014 (v19.0.2.5) Mac: prev-buffer issue
« Reply #14 on: August 18, 2015, 03:39:52 pm »
Somehow this post got pinned. Unfortunately I can't unpin it. If you are a forum admin or know how to influence one, please unpin it.  :)