Author Topic: Symbol coloring does not appear to be working  (Read 941 times)

TKasparek

  • Senior Community Member
  • Posts: 185
  • Hero Points: 23
Symbol coloring does not appear to be working
« on: September 29, 2015, 03:09:42 pm »
I can't get symbol coloring to work with v20... it shows in the sample code but will not apply to the editor windows at all.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4122
  • Hero Points: 287
Re: Symbol coloring does not appear to be working
« Reply #1 on: September 29, 2015, 04:25:03 pm »
Try restarting SlickEdit. I'm guessing a timer died.

TKasparek

  • Senior Community Member
  • Posts: 185
  • Hero Points: 23
Re: Symbol coloring does not appear to be working
« Reply #2 on: October 07, 2015, 01:10:07 am »
Restarting SE did not help. I tried renaming my v19 and removing the v20 config directory with beta two, and loaded with default config. The only change I made to the configuration was change the color scheme to black and select the All symbols - Dark background symbol color scheme. Open a project, wait for the tagging to finish restart and still nothing.
The main color scheme comes through fine but no symbol color scheme settings are applied. Even in the sample code window within the options area.

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2326
  • Hero Points: 307
Re: Symbol coloring does not appear to be working
« Reply #3 on: October 07, 2015, 03:28:10 pm »
Symbol coloring is off by default.

Appears to work for me, as soon as I turn it on.  These are the steps I took:

1) Launch Slickedit 2015 with a default config (vs -sc C:\temp\test33\)
2) Set color scheme to Black
3) Hit "Finish" to close Quick Start dialog (without building tag files).
4) Project > All Workspaces > Sample Workspaces > VS 2013.vpw
5) Open cpp.cpp and scroll down to line 81.
6) View > Symbol Coloring > Enable Symbol Coloring...

A few notes:

a) Symbol Coloring waits for background tagging jobs to finish before kicking in.
b) Version 20 has an updated tag database format, so expect it to want to rebuild your workspace tag file from scratch on first invocation.
c) Turning on Symbol Coloring from the View menu is a temporary (per-file) setting.  If you want to enable it permanently for any given Language you'll need to go to View > C/C++ View Options and check Symbol Coloring.

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2326
  • Hero Points: 307
Re: Symbol coloring does not appear to be working
« Reply #4 on: October 14, 2015, 09:31:56 pm »
FYI, there was a bug in Beta 2 that could cause Symbol Coloring to not wake up after background tagging finished.  It is fixed in Beta 3.