Author Topic: project-compile (Alt-F10) says "Command is disabled for this object"  (Read 2874 times)

jaymmartin

  • Community Member
  • Posts: 51
  • Hero Points: 8
If I goof around with the project properties (change, then unchange something, press OK), it works... until next time Slickedit is run.


Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4691
  • Hero Points: 379
Re: project-compile (Alt-F10) says "Command is disabled for this object"
« Reply #1 on: October 01, 2015, 11:58:49 am »
Which beta version are you running (1 or 2)?

What project type did you create this project from? Or did you open a 3rdparty workspace?

Thanks

jaymmartin

  • Community Member
  • Posts: 51
  • Hero Points: 8
Re: project-compile (Alt-F10) says "Command is disabled for this object"
« Reply #2 on: October 01, 2015, 05:44:33 pm »
Beta 2.
Project/New/"Other C/C++"
Playing around, it happens when I specify the project file (.vpw) on the slickedit command-line.  If I switch the project (and then back) in the editor.  It works again.
I am running: "vs project.vpw yada.cpp" 

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4691
  • Hero Points: 379
Re: project-compile (Alt-F10) says "Command is disabled for this object"
« Reply #3 on: October 01, 2015, 08:36:44 pm »
So far, no luck reproducing this. Something must be different. I tried a default config and set the compile command to "echo %f". Start SlickEdit (vs project.vpw file.cpp) and press Shift+F10 to compile. Works fine. I tried the "(other)" project and a couple others. Works fine. I also tried Brief emulation which uses Alt+F10 for project-compile. Still works find right after startup.

I don't know what's different. If you create a new toy project, do you still get the problem? If you try a default config ("vs -sc <tempconfigdir> ..."), do you still get the problem?

jaymmartin

  • Community Member
  • Posts: 51
  • Hero Points: 8
Re: project-compile (Alt-F10) says "Command is disabled for this object"
« Reply #4 on: October 01, 2015, 10:37:34 pm »
Something evil is in my SE configuration as when I use a new config there is no problem.  Rebuilding config from scratch....

jaymmartin

  • Community Member
  • Posts: 51
  • Hero Points: 8
Re: project-compile (Alt-F10) says "Command is disabled for this object"
« Reply #5 on: October 01, 2015, 10:43:12 pm »
The problem is with the auto-restore options if I disable them, the problem occurs.


Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4691
  • Hero Points: 379
Re: project-compile (Alt-F10) says "Command is disabled for this object"
« Reply #6 on: October 01, 2015, 11:02:56 pm »
Hmm...still no luck reproducing this. Export your options so I can import them (post the .zip file). I tried turning off some or all Auto Restore options but no luck reproducing this.

jaymmartin

  • Community Member
  • Posts: 51
  • Hero Points: 8
Re: project-compile (Alt-F10) says "Command is disabled for this object"
« Reply #7 on: October 02, 2015, 01:41:30 am »
Here's how to reproduce:
(1) Start with clean config.
(2) Make project "test.vpw": C/C++ Other:  Use echo %n%e for compile command.
(3) Run "vs test.vpw test.cpp"  and project-compile/Alt-F10.  (Should work).
(4) Change "Auto restore workplace files" to off and exit.
(5) Run "vs test.vpw test.cpp" and project-compile will not work.

Lee

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1249
  • Hero Points: 125
Re: project-compile (Alt-F10) says "Command is disabled for this object"
« Reply #8 on: October 02, 2015, 07:32:17 pm »
Thanks for the info.  I was able to reproduce this and a fix will be coming in the next beta release.