Author Topic: Find dialog in recording macros not working as expected  (Read 2245 times)

curtiswren

  • Community Member
  • Posts: 17
  • Hero Points: 3
Find dialog in recording macros not working as expected
« on: October 08, 2015, 06:24:11 pm »
If I have a file with the following text:
filename: details
filename: details

Then I do the following:
<Ctrl-Home>        // Move cursor to top, left
<Alt-M> R            // Begin recording macro
<Alt-S> F             // Popup Find and Replace dialog
: <Enter>             // Search for first ':'
<Shift-End>          // Select from ':' to end of line
<Backspace>        // Delete selection
<Alt-M> R            // Stop recording macro
<Esc>                  // Close Save Macro dialog
<Alt-M> x             // Execute last macro

I would expect replaying the last macro would find the next ':' and delete it to the end of the line.  I tested in an older version of slick edit and that did work.  In this beta, it does nothing.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5958
  • Hero Points: 467
Re: Find dialog in recording macros not working as expected
« Reply #1 on: October 08, 2015, 06:41:25 pm »
It appears that the <Shift-End>  key press is deleting a line (the find) when it shouldn't. Thanks for noticing.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5958
  • Hero Points: 467
Re: Find dialog in recording macros not working as expected
« Reply #2 on: October 08, 2015, 08:25:29 pm »
Fixed for next beta