Author Topic: RC5 - tab stops changed after SystemVerilog beautify  (Read 767 times)

tim_k

  • Community Member
  • Posts: 89
  • Hero Points: 4
RC5 - tab stops changed after SystemVerilog beautify
« on: November 04, 2015, 04:27:14 pm »

When testing some of the SystemVerilog beautify updates, I discovered that when beautifying anything in a file, the tab stops changed from the +2 in the Languages->All Languages->Formatting dialog to +4. I can't find a tab stop setting in any of the language specific options. Am I missing something? if not, please bring back language specific tab settings (and fix the issue). If I am missing something, how do I change it?

-Tim

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 782
  • Hero Points: 40
Re: RC5 - tab stops changed after SystemVerilog beautify
« Reply #1 on: November 04, 2015, 05:07:17 pm »
The fastest way to get to the SystemVerilog tab settings is to have a SystemVerilog file open, and then go to Tools -> Beautify -> Edit Current Profile, and then go to the Indent page.  You can also reach it from the Formatting page if you go to Document -> SystemVerilog Options.

I'll look into the All Languages problem.

tim_k

  • Community Member
  • Posts: 89
  • Hero Points: 4
Re: RC5 - tab stops changed after SystemVerilog beautify
« Reply #2 on: November 04, 2015, 10:42:15 pm »
I've been staring at this screen too long. I didn't even see the indent options in the beautify profile editor.

Also, the issue I described wasn't that the tab stops in the all languages settings got changed, but rather the setting wasn't applied to the file after beautification, but the +4 was. But only for files that had been beautified, the rest retained the +2 tab stops.

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 782
  • Hero Points: 40
Re: RC5 - tab stops changed after SystemVerilog beautify
« Reply #3 on: November 05, 2015, 02:32:09 pm »
I think that describes what I'm seeing as I look at this bug.  When it works, All Languages should both update the indent/tab settings in your profile, and also update the per-buffer indent/tab settings for any open buffers.   The bug prevents this for Verilog, SystemVerilog and some other languages.  Curiously, the same functionality works for the Tools -> Quick Start Configuration, so if anyone needed a workaround for this before we fix it, that would be it.