Author Topic: Disabling 'Select a Command Parameter' dialog box  (Read 1143 times)

b

  • Senior Community Member
  • Posts: 305
  • Hero Points: 26
Disabling 'Select a Command Parameter' dialog box
« on: November 10, 2015, 11:54:46 pm »
I am not sure what I did in the command mode prompt, but now every time I press the <tab> to expand something, I get a pop up dialog box with the list of options (rather than it just expanding and showing alternate responses that a <tab> will cycle through.   

What is the command, config, or whatever to revert this back?

b

  • Senior Community Member
  • Posts: 305
  • Hero Points: 26
Re: Disabling 'Select a Command Parameter' dialog box
« Reply #1 on: November 19, 2015, 06:26:23 pm »
I finally encountered what appears to getting this in this mode.

If you highlight some text and then execute a surround (whatever / menu or command line), it appears that all subsequent slickedit command mode commands will always use a dialogue pop up rather than allowing you to tab through the options.

That is, I'm using vim emulation, so when I press ^A to get the slickedit command line and then say want to open a file (e.g., 'e foo<tab>'), it will now always use a dialogue rather than show the drop down of the available options and allow <tab> to cycle through the options (or editing of the command).

The only way I've seen to revert it back to this is the kill the vs_exe process so that whatever configuration change was made with the surround selection isn't saved.   

I'd still like to know what the configuration parameter is to change it back, and also think this is a bug as it appears that the option is changed on the fly and not reverted back.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4938
  • Hero Points: 404
Re: Disabling 'Select a Command Parameter' dialog box
« Reply #2 on: November 19, 2015, 10:18:12 pm »
Couldn't reproduce this. I tried a surround menu item, hit Ctrl+A, and did "e junk<tab>" and got the modeless list I could tab through.

b

  • Senior Community Member
  • Posts: 305
  • Hero Points: 26
Re: Disabling 'Select a Command Parameter' dialog box
« Reply #3 on: November 21, 2015, 12:35:43 am »
I'll have to keep play with this as I'm seeing hit and miss with what I'm seeing.