Author Topic: Linux - Brief-paste of column selection moves cursor funny  (Read 1385 times)

astromme

  • Community Member
  • Posts: 89
  • Hero Points: 0
Linux - Brief-paste of column selection moves cursor funny
« on: December 11, 2015, 12:25:34 am »
In the past when I column selected, then brief copy + (copy-to-clipboard), then brief-paste, the text is inserted and the cursor moves down the number of lines inserted.

Now when I insert, the cursor moves down but also one space to the left which stops me from pasting many times.

This happens on Linux (guest on Windows host) but not Windows.  This happens off a clean install as well as my previous settings.

SlickEdit Pro 2015 (v20.0.0.12 32-bit)

Serial number: WLXXXXXX
Licensed number of users: Single user
License file: /opt/slickedit-pro2015/bin/slickedit.lic

Build Date: November 10, 2015
Emulation: Brief

OS: Linux
OS Version: Ubuntu 14.04.3 LTS
Kernel Level: 3.13.0-71-generic
Build Version: #114-Ubuntu SMP Tue Dec 1 02:35:20 UTC 2015
Processor Architecture: i686

X Server Vendor: The X.Org Foundation
Memory: 14% Load, 532MB/3565MB Virtual
Shell Information: /opt/slickedit-pro2015/bin/secsh -i
Screen Size: 1920 x 976, 1920 x 1016

astromme

  • Community Member
  • Posts: 89
  • Hero Points: 0
Re: Linux - Brief-paste of column selection moves cursor funny
« Reply #1 on: December 11, 2015, 01:51:35 am »
In Editing->Selections->Styles I unchecked Inclusive Block Selection and it works without the cursor shift; however, this is different than what my Windows settings are.. just something off in the Linux version?

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4120
  • Hero Points: 287
Re: Linux - Brief-paste of column selection moves cursor funny
« Reply #2 on: December 11, 2015, 05:24:05 pm »
One difference with v20 verses prior version like v19 is that the SlickEdit will now use the default text code page even if its Utf-8.

That means SlickEdit is using your default Unicode file font. I would suggest making sure your default Unicode font is a fixed font. That should do the trick for you.

astromme

  • Community Member
  • Posts: 89
  • Hero Points: 0
Re: Linux - Brief-paste of column selection moves cursor funny
« Reply #3 on: December 11, 2015, 06:41:06 pm »
Sorry, I'm having parsing errors on your reply :)

"making sure your default Unicode font is a fixed font" - I'm using DejaVu Sans Mono - as far as I know it's a fixed font.  I'm using it for both SBCS/DBCS Source Windows as well as Unicode Source Windows in both Windows and Linux.  Fixed Fonts Only is checked in both Windows and Linux.

If I block copy and leave the Options window open on Editing->Selections, then paste, toggle Inclusive block selection and paste again, I get the strange behavior where the next paste is 1 column to the left when Inclusive block selection is active - but this occurs on Linux and not Windows.

One other difference between Windows and Linux is on Linux, at the bottom of screen to the right of the Ins/Rep field that changes with insert-toggle, if the cursor is on a lower case e on Linux I see U+0065 vs Windows I see 65.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4120
  • Hero Points: 287
Re: Linux - Brief-paste of column selection moves cursor funny
« Reply #4 on: December 11, 2015, 07:16:45 pm »
The status line difference is normal for Unicode vs code page text.

Post some sample test and directions to reproduce. I wasn't able to reproduce the problem with non problematic Unicode text. Technically there's no such thing as a fixed Unicode font but it works for a limited character set.

astromme

  • Community Member
  • Posts: 89
  • Hero Points: 0
Re: Linux - Brief-paste of column selection moves cursor funny
« Reply #5 on: December 11, 2015, 07:50:33 pm »
1. Open a new file
2. Create 6 lines of asdf
3. Block select two lines of "sd" (I use Alt-C, mapped to brief-select-block)
4. Copy (I use brief's pad plus, mapped to copy-to-clipboard)
5. Position the cursor at the end of the first line
6. Open Tools->Options->Editing->Selections
7. Verify Inclusive block selection is not selected (if it is, uncheck it and Apply changes)
8. Go back to the window and paste three times (I use Ins, mapped to brief-paste)
9. Verify the window shows 6 lines of "asdfsd"
10. Undo three times (get back to 6 lines of "asdf"
11. Check "Inclusive block selection" - note that the Styles radio button switches to CUA
12. Apply changes in the Options dialog
13. Go back to the window and paste three times

After step 13, on Linux my window has this (incorrect) text:
asdfsd
asdfsd
asdsdf
asdsdf
assddf
assddf

After step 13, on Windows my window has this (expected) text:
asdfsd
asdfsd
asdfsd
asdfsd
asdfsd
asdfsd


If I use Ctrl-V mapped to paste, I get this in both Windows and Linux:
asdfsdsdsd
asdfsdsdsd
asdf
asdf
asdf
asdf

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4120
  • Hero Points: 287
Re: Linux - Brief-paste of column selection moves cursor funny
« Reply #6 on: December 11, 2015, 09:57:37 pm »
Thanks for finding this. Fixed for 20.0.1. Expected to be available next week.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4120
  • Hero Points: 287
Re: Linux - Brief-paste of column selection moves cursor funny
« Reply #7 on: December 14, 2015, 07:35:39 pm »
20.0.1 is available for download

garion911

  • Senior Community Member
  • Posts: 184
  • Hero Points: 13
Re: Linux - Brief-paste of column selection moves cursor funny
« Reply #8 on: December 14, 2015, 08:05:05 pm »
I have a similar and new problem with 20.0.1.2 on OSX.

Again, Brief, dealing with column select. In Python mode (and C mode), I created something like this:

Code: [Select]
def test():
    #test1()
    #test1()
    #test1()

Now if I column select the hash (#) on all three lines, and hit delete to uncomment them, it deletes a space in front of the # (but not the hash itself), and places the cursor in the first column. Duplicating this in C code does the same thing.. Comments are not necessary, it happens with all code I tried it on. It only seems to happen when you have a single column selected.

I don't think happened on the previous version 20.0.0.X, because I do this type of edit constantly, and would have noticed.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4120
  • Hero Points: 287
Re: Linux - Brief-paste of column selection moves cursor funny
« Reply #9 on: December 14, 2015, 08:25:35 pm »
Reproduced. We will make a hot fix for this. You can work around this by using cut (PadMinus).