SlickEdit Product Discussion > SlickEditĀ®

SlickEdit v11.0.1 patch unacceptable

<< < (2/3) > >>

pvonkaenel:

--- Quote from: SashaK on July 14, 2006, 07:16:12 pm ---Same error parsing problem here.
Also SE freezes now when build command calls external make file and capturing output to build window.
Just did fresh reinstall, problem remains. Rolling back to v11.0

/sasha

--- End quote ---

I'm not sure if this applies to you or not, but if you're building Visual Studio 2005 solutions in Slickedit, the build output hangs until the build completes.  This is actually a Microsoft bug that also affects the standard command line.  They are aware of the problem and say it will be fixed in SP1 due out this fall.  I kind of wish they would release a hotfix for this.

As for the error parsing, I haven't had any problems with it since installing the 11.0.1 patch.

Peter

eruisi:
I have the same problem. Each time I diff files with files on the CVS serer, SE hangs.

jeffcobb:
A little more information although probably not enough. 11.01 under linux (specifically Ubuntu breezy running on an AMD 64 X2) I have noticed the sequence as:
1. Add pre-existing make-style project to existing workspace.
2. Add files to project.
3. Set compile and build commands to make and 'make clean && make' respectively.
4. Set the active project to the new project.
5. Hit build.
Gets to what could be the final link stage and it locks VS harder than a rock. Only a sudo killall vs gets me out. If I just reopen the app (and thus all projects) the project now builds fine and seems to work from then on.

And before anyone suggests it, I have already tried saving the new project, closing vslick, reopening everything and trying the build that way; no joy. Its like the first build is cursed no matter if it is deferred or what. I know I can shell out and just run make myself (do it all the time) but then I have to ask the obvious question then: WTF did I just shell out 300 bones for?

SlickEdit Support:
Here is a new error.e file that should solve the problem for you.  (This will fix the goto/next-error and Build/Hang issues.)

1.)  Make a backup of error.e in your SlickEdit\macros\ directory.  (DO NOT DELETE error.ex and DO NOT UNLOAD the error.ex MODULE FROM SLICKEDIT.)

2.)  Save this attached file to your SlickEdit\macros\ directory and reload via macros-->Load MODULE.

Regards,
SlickEdit Support

jbezem:
It changes something, however, not all's well for me.
As I wrote to SE support by mail: After startup, SE's reactions on 'cursor_error' have changed in that it tries to interpret the line under the cursor.
However, the regular expressions I have active (ErrorRE.xml) are not recognized until I have performed a 'reset-next-error' (or recompile error.e), as before. Reproducible on every new start of SE.

Regards,

Johan

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version