Author Topic: file modes... grrrr...  (Read 3331 times)

dunkers

  • Senior Community Member
  • Posts: 735
  • Hero Points: 32
file modes... grrrr...
« on: May 17, 2007, 07:37:59 pm »
Just checked in a project to svn which happened to need a merge. It failed, so I did an update and that failed quite dramatically too. Couldn't fix it, couldn't check it in. Then I noticed I had SE open... closed that and the project checked in without problems.

That would be bad enough, but now SE thinks all the files are RO. They aren't, but SE shows RO for all of them. Fortunately, this is a side project of just a dozen or so files rather than the 20K file biggy...

Can some nice person at SE assure us that this open file business will be fixed in the upcoming service pack?

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2514
  • Hero Points: 139
Re: file modes... grrrr...
« Reply #1 on: May 17, 2007, 08:00:44 pm »
I have a couple more questions for you:

  • Are these very large files?
  • Were you checking them in from the editor, or from outside but you had them up in the editor?

dunkers

  • Senior Community Member
  • Posts: 735
  • Hero Points: 32
Re: file modes... grrrr...
« Reply #2 on: May 17, 2007, 08:27:46 pm »
A mix of files from 11 lines to 750 lines in length.

I was checking them in from outside the editor - actually via a context menu in DOpus (nice Explorer replacement) via TortoiseSvn (a Windows GUI wrapper around svn). SlickEdit had the files in edit buffers but was minimised at the time.

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2514
  • Hero Points: 139
Re: file modes... grrrr...
« Reply #3 on: May 17, 2007, 08:35:08 pm »
It sounds like the problem is that SlickEdit still had the file open (locked).  By default, SlickEdit load the whole file for a file under 500k, and frees the file handle.  Can you check your settings on the "Load" tab of the File Options dialog (Tools>Options>File Options).

dunkers

  • Senior Community Member
  • Posts: 735
  • Hero Points: 32
Re: file modes... grrrr...
« Reply #4 on: May 17, 2007, 11:45:55 pm »
Dan, in checking the file options (see screencap) I think I've spotted the problem - the file locking tickbox is checked. Duh!

I have to humbly apologise here because that's obviously going to make a mess if, say, I've got a log file in an edit buffer for viewing and some external app wants to write to it. This is, in fact, one of my whinges.

I have no idea how this got to be set. Maybe my upgrade to SE12 slipped it in and I just never thought to check.