Author Topic: Is SlickEdit compatable with remote debugging using GDB and ELF symbols?  (Read 2819 times)

cstout4444

  • Junior Community Member
  • Posts: 2
  • Hero Points: 0
Hi,

I am able to run and stop the program, but no other commands are possible without symbols from the ELF file. The file type that is accepted seems to be exclusively EXE. Please share any ideas on getting this to work. (SE 11.0.2)

Thanks
« Last Edit: March 23, 2007, 12:18:38 pm by cstout4444 »

twells55555

  • Community Member
  • Posts: 15
  • Hero Points: 1
Re: Is SlickEdit ELF compatable with remote debugging using GDB?
« Reply #1 on: March 22, 2007, 11:38:19 am »
 I am able to do remote debugging  with an elf file running on an arm microprocessor.  It works ok except the yellow arrow which is supposed to show what line is executing does not even show up in the source code window. Not even close.  It's usually somewhere in the project window, and sometimes another shows up down around the output window.  But the cursor does track correctly so I am able to set breakpoints and step through code ect....it's just annoying seeing the arrows off in La-la land...you may have to load a symbol file separately or something to get the cursors to sync up, but nothing I have tried has worked so far to get the arrows to sync up....but it's still useable for me as is just loading an elf file built with the debug symbol switch.

       tim