Author Topic: zfs instantly makes the buffered copy older  (Read 1433 times)

Margaret

  • Community Member
  • Posts: 70
  • Hero Points: 0
zfs instantly makes the buffered copy older
« on: March 29, 2016, 05:42:13 pm »
I finally got fed up with having files scattered around auto-decaying and built up a FreeBSD fileserver to centralise them, using zfs scrubbing to auto-protect against auto-decay.

But I now have a weird problem!  Every time I save off the file I'm working on, zfs snatches it up and scrutinises it to update its crc.   But that makes the copy in the editor (v9.0) "older" than the one on disk, which prompts  a prompt:  "are you silly enough to want to replace the newer, shinier file on disk with this older, grotty one?" (okay, not quite that wording, but the sentiment's accurate.  Fsvo accurate)  ;D

I don't want to auto-update the file in the buffer because of having had files stepped on and then auto reloaded in their crumbled state.

Is there some other simple solution?  Surely one of the thousands of people who adopted zfs years ago had this problem and solved it to keep themselves from being driven mad.
« Last Edit: March 29, 2016, 06:50:37 pm by Margaret »

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2919
  • Hero Points: 438
Re: zfs instantly makes the buffered copy older
« Reply #1 on: March 29, 2016, 08:30:07 pm »
I do not remember if v9.0 had this, but under File Options > Auto reload, there is an option to "Compare file contents before auto reload".  With this enabled, SlickEdit would detect that even though the modification date of the file changed, the actual file contents had not changed, and it would not prompt to auto-reload.

Margaret

  • Community Member
  • Posts: 70
  • Hero Points: 0
Re: zfs instantly makes the buffered copy older
« Reply #2 on: March 31, 2016, 11:02:50 am »
Saddeningly, v9 doesn't have it.