Author Topic: Autocomplete does not work for headers files  (Read 1032 times)

Viterzgir

  • Junior Community Member
  • Posts: 6
  • Hero Points: 0
Autocomplete does not work for headers files
« on: April 16, 2016, 11:59:02 am »
Slickedit 2015 has not shown suggestion autocompletion for headers files, such as iostream, limit ,vector in c++ projects . Show only symbols with " .h" extension

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2522
  • Hero Points: 367
Re: Autocomplete does not work for headers files
« Reply #1 on: April 19, 2016, 04:14:16 pm »
It should pick up those things for your compiler tag file automatically.  You can also use the extensionless file mapping options to tell Slickedit that specific directories contain extensionless files that are to be treated as C++ headers.

Also, for future reference, it is a very useful to state what platform and what compiler you are working with.

mjdl

  • Senior Community Member
  • Posts: 138
  • Hero Points: 14
  • SE 23 RC1 x64 Windows 10 1803 x64 16GB w/SSD
Re: Autocomplete does not work for headers files
« Reply #2 on: April 22, 2016, 09:07:58 pm »
For what it's worth, and to save people point & click time, attached is a Slickedit Options export file for the Extensionless Files Options with most of the C/C++ Standard Library header files.

Make sure you save a Slickedit Options export backup zip file before you import my file!

Viterzgir

  • Junior Community Member
  • Posts: 6
  • Hero Points: 0
Re: Autocomplete does not work for headers files
« Reply #3 on: May 01, 2016, 05:12:43 pm »
Hello Dennis. I'm using Slickedit v20.0.2.1 64-bit on linux and gcc 5.3.0.