Author Topic: Problems Saving New File  (Read 1886 times)

PiezonTM

  • Senior Community Member
  • Posts: 131
  • Hero Points: 7
Problems Saving New File
« on: April 21, 2016, 01:05:41 pm »
I've created a new buffer then attempt to save.  I give it a filename and click `save`.  When the save has completed I get either a blank filename on the buffer or a filename called `*`.  No files were saved to disk either.  No matter what I do I can't get a new file to save.

I am running Ubuntu 14.04 64-bit, SlickEdit Pro 2015 (v20.0.1.3 64-bit) with hotfix_se2001_7_cumulative.zip


,

PiezonTM

  • Senior Community Member
  • Posts: 131
  • Hero Points: 7
Re: Problems Saving New File
« Reply #1 on: April 21, 2016, 01:07:58 pm »
Figured it out, there was a permissions problem on the directory so it couldn't save the file.  It would be nice if it would report an error that it could not write the file.

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1659
  • Hero Points: 141
Re: Problems Saving New File
« Reply #2 on: April 21, 2016, 01:17:22 pm »
Yeah, reproduced when writing to a location without write permissions.  That's a bug, thanks for the report.  I'm not sure if it's hot-fixable yet, but if it is, we'll put it in a hotfix.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 6203
  • Hero Points: 481
Re: Problems Saving New File
« Reply #3 on: April 21, 2016, 02:21:22 pm »
Good catch! This has got to be a really old bug. This can be hot fixed.