Author Topic: Can't register SlickEdit through web, get no response from support.  (Read 7855 times)

boo

  • Community Member
  • Posts: 16
  • Hero Points: 0
[ current issue ]

It has been some weeks and the SlickEdit website still has not registered a product with the serial number that I supplied. Cannot obtain SlickEdit 2007 without it.

[ real issue ]

My Slickedit configuration informs me when there are patches or upgrades made available on a daily basis.

CAS-15165 was filed on January 9, 2006. The last correspondence received from SlickEdit was that the problem could not be reproduced and the case froze since then. I thought a couple of pictures and a detailed walkthrough would have been easy to spot but it did not turn out that way.

I'm reminded daily that every time I create or open a new instance of a new workspace that all the bookmarks that I made will be lost. Debugging, deadlisting, and multitasking work across several releases on top of daily development really causes me to lose track of all the earmarked pieces of code that I want to review at a later time. Typically I go through about 10 to 30 workspaces a day, sometimes more, depending on the amount of customer issues on their particular setup.

I created a simple perl script to create a new default workspace files (.vpw) to add a subset of all the files from any particular build. Other than this, the final command gives a new/unique configuration location and a new/unique restore location like so:

  vs.exe +new -sc $new_config_path\\config -sr $new_restore_path $new_workspace_path\\services.vpw

The bookmarks are lost upon closing the new workspace. This test can be done manually and has been 100% repeatable in SlickEdit v10 and v11.

The maintenance releases give some hope that the issue would be fixed, but my luck seems to be running low. Would anyone be able to look into this problem again? Or if anyone else has a suggestion I'm all ears.

hs2

  • Senior Community Member
  • Posts: 2732
  • Hero Points: 284
Re: Can't register SlickEdit through web, get no response from support.
« Reply #1 on: March 29, 2007, 08:03:00 pm »
Not sure if it's related, but since v11 bookmarks (if configured per workspace (General Options -> ??? (Search in v12) -> Use workspace bookmarks) are stored in the *.vpwhist file belonging to the *.vpw file w/ the same name (prefix).

If you generate new vpw files to open them afterwards you should use global bookmarks (and uncheck 'workspace bookmarks').

Did you also configure 'General Options->Exit-> Save config on exit' ?

HS2

bcernohous

  • Community Member
  • Posts: 12
  • Hero Points: 0
Re: Can't register SlickEdit through web, get no response from support.
« Reply #2 on: April 01, 2007, 03:49:48 am »
I have the issue with registering.  I recently bought and registered slick edit.  I get daily reminders about the upgrade but no products are listed as registered for me on the web page.  I didn't try support but noticed this topic on the rss.

Jeffrey

  • Community Administrator
  • Senior Community Member
  • *
  • Posts: 222
  • Hero Points: 18
Re: Can't register SlickEdit through web, get no response from support.
« Reply #3 on: April 01, 2007, 05:52:42 pm »
Our regsistration process works like this:

You submit your serial number via a webform after making a web account.  Our sales group reviews the request to link the serial number to your web account.  (Believe it or not, we actually have people try to register serial numbers that we've never sold, serials known to be pirated, serial numbers that belong to other customers, and occasionally some of our larger corporate customers ask that all registrations be centralized with one person.)

We do our very best to complete this registration verification process in 1 business day or less.  You should never need to wait more than two business days.    Our sales group would like to assist you in resolving your registration issues and get you the latest version  of SlickEdit.   

Please send an email to sales@slickedit.com with your website email and serial number, and we'll get you handled same day.

Sorry for any inconvienience.

--Jeffrey

boo

  • Community Member
  • Posts: 16
  • Hero Points: 0
Re: Can't register SlickEdit through web, get no response from support.
« Reply #4 on: April 03, 2007, 09:38:43 pm »
Not sure if it's related, but since v11 bookmarks (if configured per workspace (General Options -> ??? (Search in v12) -> Use workspace bookmarks) are stored in the *.vpwhist file belonging to the *.vpw file w/ the same name (prefix).

If you generate new vpw files to open them afterwards you should use global bookmarks (and uncheck 'workspace bookmarks').

Did you also configure 'General Options->Exit-> Save config on exit' ?

HS2

The interesting property is that the bookmarks are getting stored in the .vpwhist file, but SlickEdit fails to reload them after reopening a closed workspace. There's probably a bug linked to the command-line option "+new". The guess is SlickEdit doesn't handle between workspace and global bookmarks.

Your suggestion for "save config on exit" is already enabled--.vpwhist file contains all the bookmarks per workspace just fine.

I'm thinking your other suggestion to configure bookmarks per workspace instead of using global bookmarks (reversed of what you said) could be the ticket to solving my problem. (Using a global bookmarks would make life difficult in my work environment).

I don't see this option in SlickEdit V11. Will try to get a hold of V12 from our SW rep, but now I'm really optimistic for this new version  :-X

Thanks!

hs2

  • Senior Community Member
  • Posts: 2732
  • Hero Points: 284
Re: Can't register SlickEdit through web, get no response from support.
« Reply #5 on: April 03, 2007, 11:03:57 pm »
You can try that even with v11:
On cmdline: 'set-var def_use_workspace_bm 1' to enable ('0' disables it again)

HS2

boo

  • Community Member
  • Posts: 16
  • Hero Points: 0
Re: Can't register SlickEdit through web, get no response from support.
« Reply #6 on: April 04, 2007, 12:48:35 am »
Just got my copy of Slickedit 2007 (that was quick) and OMG the bookmark issue is fixed!!!

Thanks all for pitching in!