Author Topic: Beta2 Redo bug  (Read 1274 times)

jporkkahtc

  • Senior Community Member
  • Posts: 1972
  • Hero Points: 185
  • Text
Beta2 Redo bug
« on: July 30, 2016, 10:44:28 pm »

Beta2
Load "C:\Program Files\SlickEdit Pro 21.0.0 Beta2\macros\tbfind.e"
UndoAffectsCursorMovement:off
Undo bug


abc
<down><down><down>
def
<up><up><up>
<undo><undo><undo>
<down><down><down>
<redo><redo><redo><redo><redo><redo>


The REDO deletes the DEF.
You should be left with the below, except Redo deletes "def".


abc////////////////////////////////////////////////////////////////////////////////////
// $Revision: 60101 $
////////////////////////////////////////////////////////////////////////////////////
// defCopyright 2010 SlickEdit Inc.


Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5305
  • Hero Points: 433
Re: Beta2 Redo bug
« Reply #1 on: July 31, 2016, 01:44:43 am »
Reproduced in beta2. Redo count is wrong.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5305
  • Hero Points: 433
Re: Beta2 Redo bug
« Reply #2 on: July 31, 2016, 02:16:42 pm »
Fixed for beta 3

jporkkahtc

  • Senior Community Member
  • Posts: 1972
  • Hero Points: 185
  • Text
Re: Beta2 Redo bug
« Reply #3 on: August 03, 2016, 08:00:50 pm »
undo/redo seems to be pretty unreliable now - but I've not been reporting other specific issues.
Often I can't undo things that I should be able to.


Do do think that Beta3 is likely to resolve this?


Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5305
  • Hero Points: 433
Re: Beta2 Redo bug
« Reply #4 on: August 03, 2016, 09:05:06 pm »
Yes. The count issue is a bad bug. Sorry.

"If you don't want any bugs, don't write any code"  ;D