Author Topic: v21Beta2/Win7: Locked up on tagging, lost my settings  (Read 1085 times)

davew

  • Senior Community Member
  • Posts: 224
  • Hero Points: 6
v21Beta2/Win7: Locked up on tagging, lost my settings
« on: August 01, 2016, 07:45:25 pm »
I created a new project and went away (to another app) for a bit. When I returned to SE, I got the "not responding" indication. I waited several minutes and force closed it. When I reopened, all of my color settings were set back to default, although my Window tabs were unchanged. I uninstalled and re-installed to get back to my original settings. I noticed that on the status line, there was an indication of an error accessing a file (probably one it was tagging). I went to the file and opened it with another editor and there was nothing wrong.

After the reinstall, I created the same project again. It looked like it was saying that ALL the files were causing errors (or at least a good number of them). I didn't see any being processed that did not have an error. Then it said Tagging (12460 remaining) and froze there. I closed it (Windows forced it).

I then created the same project in SE 20.0.3.0 and it worked fine.

The project is about 15,000 files (C and other types) and is located on a Virtual Box virtual drive partitioned on my local Solid State Drive.

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2738
  • Hero Points: 419
Re: v21Beta2/Win7: Locked up on tagging, lost my settings
« Reply #1 on: August 01, 2016, 08:31:30 pm »
If you get the lockup again, could you create a mini-dump.  That would help us trace down where the editor was locking up.

If you can reproduce the lockup and get the mini-dump, another bit of information that would be helpful would be the tagging log file.  You need to turn on def_tagging_logging (Macro > Set Macro Variable...), then reproduce the lockup, then send the min-dump and <config>/logs/tagging.log to support or post them here.

jporkkahtc

  • Senior Community Member
  • Posts: 1783
  • Hero Points: 174
  • Text
Re: v21Beta2/Win7: Locked up on tagging, lost my settings
« Reply #2 on: August 01, 2016, 09:42:17 pm »
Also in Tools > Options > Application Options > Exit, set "Save Configuration" to "Save Config Immediately".
Then you don't loose your configuration changes if slick crashes or hangs.

davew

  • Senior Community Member
  • Posts: 224
  • Hero Points: 6
Re: v21Beta2/Win7: Locked up on tagging, lost my settings
« Reply #3 on: August 02, 2016, 05:29:16 pm »
Can't repro the lockup, however there are errors on what looks like every file - even though these files are completely accessible by opening them - even in SE. Previous version (20.0.3.0) of SE does not do this. I'm attaching tagging.log (zipped).

Just to be clear, I have no tags.
« Last Edit: August 02, 2016, 06:54:28 pm by davew »

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2738
  • Hero Points: 419
Re: v21Beta2/Win7: Locked up on tagging, lost my settings
« Reply #4 on: August 02, 2016, 07:20:15 pm »
Do you have another instance of the editor running (or a zombie instance)?  It could have a write-lock on the workspace tag file.

davew

  • Senior Community Member
  • Posts: 224
  • Hero Points: 6
Re: v21Beta2/Win7: Locked up on tagging, lost my settings
« Reply #5 on: August 16, 2016, 08:03:18 pm »
Sorry for the slow response - been on vacation.
I don't know if there was a "zombie" instance. I'll keep an eye out for that if it happens again.