Author Topic: Groovy not recognized when file stored in Linux format (0x0A)  (Read 1569 times)

CyberZombie

  • Community Member
  • Posts: 23
  • Hero Points: 0
Groovy not recognized when file stored in Linux format (0x0A)
« on: August 03, 2016, 07:51:18 pm »
This is for *.groovy on Windows. If the file is in CRLF form then opening it shows syntax coloring. If LF form, no syntax - it thinks it's a plain text file. Take the CRLF, save as LF, close it, re-open - no more syntax coloring.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4896
  • Hero Points: 399
Re: Groovy not recognized when file stored in Linux format (0x0A)
« Reply #1 on: August 03, 2016, 09:58:56 pm »
I'm unable to reproduce this on Windows with Beta 2. Try starting SlickEdit with a new config.

vs +new -sc <dir-does-not-exist-yet>

If the problem goes away, we will need you to zip up your config and send it to us. Let us know if this fixes your problem.

CyberZombie

  • Community Member
  • Posts: 23
  • Hero Points: 0
Re: Groovy not recognized when file stored in Linux format (0x0A)
« Reply #2 on: August 04, 2016, 03:32:13 pm »
Thanks - everything worked with the fresh config. FWIW, this is one of the first things I did when installing the beta - which imported my 15.0.1 config. What would you like?

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4896
  • Hero Points: 399
Re: Groovy not recognized when file stored in Linux format (0x0A)
« Reply #3 on: August 04, 2016, 05:31:36 pm »
Please zip up your 15.0.1 directory and upload it. We don't need your vsdelta, tagfiles, or autosave directories.

To upload: Go to http://support.slickedit.com. Use 13652 (this topic id) for the case id.

Once it is uploaded, post here to let me know.

Thanks

CyberZombie

  • Community Member
  • Posts: 23
  • Hero Points: 0
Re: Groovy not recognized when file stored in Linux format (0x0A)
« Reply #4 on: August 04, 2016, 06:38:32 pm »
Uploaded.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4896
  • Hero Points: 399
Re: Groovy not recognized when file stored in Linux format (0x0A)
« Reply #5 on: August 04, 2016, 07:14:46 pm »
Hmm...I'm not able to reproduce this.

Here's what I did:

Clean out all preexisting config directories.
Created a 15.0.1 directory and unzipped your config files
Started v21 beta 2 so it would have to convert from your 15.0.1 config files
Opened a groovy file which only has line feeds. Document mode was groovy
Opened another groovy file which has <CR><LF> line endings. Document mode was groovy

I did these tests on Windows with beta 2.

CyberZombie

  • Community Member
  • Posts: 23
  • Hero Points: 0
Re: Groovy not recognized when file stored in Linux format (0x0A)
« Reply #6 on: August 04, 2016, 07:21:14 pm »
Okay - let me whittle away the confidential info from this groovy and see if it still breaks for me. If so, I'll upload it under the same ticket and let you know.

CyberZombie

  • Community Member
  • Posts: 23
  • Hero Points: 0
Re: Groovy not recognized when file stored in Linux format (0x0A)
« Reply #7 on: August 04, 2016, 07:31:11 pm »
I now believe it is because I had the file open in my older SlickEdit, and it got carried over as text when upgrading to the beta. I can't duplicate this with other files. Nor this one if I move it to another directory. But if I move it back in to the directory it existed in when I was editing it in the past, it's once again a text file.

Is there a way to clear that flag?

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4896
  • Hero Points: 399
Re: Groovy not recognized when file stored in Linux format (0x0A)
« Reply #8 on: August 04, 2016, 10:47:50 pm »
The mode name gets stored in various places. To reset, simple set the mode (Document>Select Mode). Choose Groovy for the mode.