Author Topic: UTF-8 Hex mode...  (Read 1564 times)

jporkkahtc

  • Senior Community Member
  • Posts: 1783
  • Hero Points: 174
  • Text
UTF-8 Hex mode...
« on: August 05, 2016, 08:41:17 pm »
I have a UTF-8 buffer (no bom).


Switch to hex
Switch to LineHex
Switch to normal
Modify the file.


Switch to hex
I can switch into Hex mode without saving.

[/size]Switch to normal

---------------------------
SlickEdit Pro
---------------------------
Switching out of hex mode for this file requires reloading this Binary file in its original encoding.


Save changes to 'C:\src\sdk3\log.txt'?
---------------------------
Cancel   &Yes   &No   
---------------------------






Seems like if I can go to Hex without saving, I should be able to return to normal without saving.

« Last Edit: August 05, 2016, 08:43:15 pm by jporkkahtc »

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4791
  • Hero Points: 388
Re: UTF-8 Hex mode...
« Reply #1 on: August 05, 2016, 10:38:30 pm »
That's a bug. Switching into LineHex from Hex for that file seems to confuse it.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4791
  • Hero Points: 388
Re: UTF-8 Hex mode...
« Reply #2 on: August 06, 2016, 01:51:02 am »
Fixed for beta 3

jporkkahtc

  • Senior Community Member
  • Posts: 1783
  • Hero Points: 174
  • Text
Re: UTF-8 Hex mode...
« Reply #3 on: August 22, 2016, 09:36:11 pm »
There is something still wrong here with diff.

Open a utf-8 file.
Hex mode.
Diff - compare it to another utf-8 file.

Now the DIFF seems like it turned off hex mode, but the diff isn't right.
Diff shows both files as completely different.

Also, once you close Diff, the file is no longer in hex mode but the encoding is left as binary.


I think because one is in Binary mode now, and the other UTF-8.

But .... Diff didn't prompt to convert encodings like it usually does when two files have different encodings.


Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2357
  • Hero Points: 131
Re: UTF-8 Hex mode...
« Reply #4 on: September 07, 2016, 02:39:12 pm »
Fixed for the next build.