Author Topic: syntax highlighting not working on some C files  (Read 751 times)

marcos91360

  • Community Member
  • Posts: 10
  • Hero Points: 0
syntax highlighting not working on some C files
« on: August 09, 2016, 08:50:17 pm »
I have a handful of c files that where the syntax highlighting is not working at all; other files in the same path are fine. I have verified the settings and there is nothing obvious I can see. Does anyone know how to resolve this odd issue?

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 748
  • Hero Points: 36
Re: syntax highlighting not working on some C files
« Reply #1 on: August 09, 2016, 09:13:48 pm »
If you open up one of the problem files, and open the Document menu, up at the top there will be an entry that says "Select Mode (CURRENT MODE NAME)".  Does it show the mode as C/C++?   If not, you can set the mode to C/C++ with that menu entry. 

marcos91360

  • Community Member
  • Posts: 10
  • Hero Points: 0
Re: syntax highlighting not working on some C files
« Reply #2 on: August 09, 2016, 10:14:08 pm »
Thanks. It said "Plain text", not sure why as it is a .c file AND other files in the same directory opened just fine. Once again thanks

davew

  • Senior Community Member
  • Posts: 199
  • Hero Points: 5
Re: syntax highlighting not working on some C files
« Reply #3 on: October 25, 2016, 05:53:07 pm »
I have the same issue. I've never had this problem before v21. I'm on the hotfix 2. I found that if I save the file to any other folder, it highlights correctly but if I save it to the same folder it is plain text. Other files in the folder are OK as well.

I'm using the suggested workaround, but this seems to a bug that needs fixing.