Author Topic: v12 Write on Loss of Focus - Doesn't  (Read 3953 times)

Thom Little

  • Community Member
  • Posts: 83
  • Hero Points: 2
v12 Write on Loss of Focus - Doesn't
« on: April 03, 2007, 02:37:18 pm »
I have Write on Loss of Focus enabled.  I rely on it heavily.

I have a macro that is called from Save() that updates the current date and time in a field of the source file.

I have a macro that “touches” each active buffer and turns on the “change bit”.

To finalize a group of files I load them all into buffers, turn on the change bit, and then I change focus outside SlickEdit they are all written to disk.

This sometimes does not work in v12.  Sometimes it does.  Sometimes only the buffer with focus is written.  Sometimes only the buffer with focus and one other buffer is written.

(With the tab toolbar … the first macro turns all the tabs red … change of focus results in some of the tabs being reset to black and some remaining red.   In v11 on change of focus they are all returned to black.)

I discovered this was happening today at 2 AM when I was getting illogical results in a module I was debugging.

... Thom

Lee

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1299
  • Hero Points: 130
Re: v12 Write on Loss of Focus - Doesn't
« Reply #1 on: April 03, 2007, 09:39:47 pm »
A bug was recently discovered in SlickEdit 2007 with Save all, that would also affect things like "Save files on loss of focus" or using Save all in project properties for build tools, and a few other cases as well.  A hotfix is available for this, contact support@slickedit.com, and they will send out the latest cumulative hotfixes to you.  The changes should not affect any custom macros you have written, but just let us know if it does.

Thom Little

  • Community Member
  • Posts: 83
  • Hero Points: 2
Re: v12 Write on Loss of Focus - Doesn't
« Reply #2 on: April 03, 2007, 11:21:31 pm »
Thanks for the information.

(For the record ... I never used the "B" word.)

... Thom