Author Topic: Perl beautify error  (Read 1125 times)

neurobashing

  • New Community Member
  • Posts: 2
  • Hero Points: 0
Perl beautify error
« on: September 18, 2016, 12:11:17 am »
On attempting to beautify the current Perl buffer, I get an error: "Could not load profile named '' for pl, error=-102302". Likewise "beautify while typing" is greyed out under Document in the menubar.

SlickEdit Pro 2016 (v21.0.0.7)

Serial number: FE75807_BETA
License type: Beta License
License expiration: 2016-10-30 20:00:00
License file: /Library/Application Support/SlickEdit/21/slickedit.lic

Build Date: September 12, 2016
Emulation: BBEdit

OS: macOS
OS Version: 10.11.6
Processor Architecture: Intel(R) Core(TM) i7-4770HQ CPU @ 2.20GHz 64 bit (8 cores)

Memory: 48% Load, 7890MB/16384MB Virtual
Shell Information: /Applications/SlickEditPro2016.app/Contents/MacOS/secsh -i
Screen Size: 1440 x 900

Project Type: Single file project - Perl
Language: .pl (Perl)
Encoding: Automatic


Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5146
  • Hero Points: 425
Re: Perl beautify error
« Reply #1 on: September 19, 2016, 02:57:55 am »
SlickEdit doesn't have a beautifier for Perl. The beautifier menu items should all be disabled.

Is the Tools>Beautify>Beautify menu item enabled for you for Perl files?

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1238
  • Hero Points: 119
Re: Perl beautify error
« Reply #2 on: September 19, 2016, 01:41:17 pm »
That looks like the error message you get when running the beautify-current-buffer or beautify-with-profile command.  You know what command you ran, or did you access it from a menu or toolbar button?

While the message is technically correct, in this case it should probably say something more along the lines of "This language is not supported".