Author Topic: RC2: Can't put cursor where I want in an xml file  (Read 3020 times)

rowbearto

  • Senior Community Member
  • Posts: 1167
  • Hero Points: 73
RC2: Can't put cursor where I want in an xml file
« on: September 22, 2016, 09:14:18 pm »
Attached is an xml file.

Open the file in SE, then using the mouse, place the cursor at the end of line 55, after the >, and click the mouse button so that the cursor is just after the > in:

Code: [Select]
        <parameter name="cellmode"    value="MONO_CELL"/>
After the cursor is there, now place the mouse between the 2 Ls in MONO_CELL. Click the left button. The cursor does not move there. If you click a 2nd time, it may go there, but not the first. Try similar exercise on other lines that end with a '>'

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4481
  • Hero Points: 344
Re: RC2: Can't put cursor where I want in an xml file
« Reply #1 on: September 22, 2016, 11:03:50 pm »
I haven't been able to reproduce this. It is pixel sensitive. As long as my mouse pointer is at least have past the beginning of the first L, then the cursor ends up at the start of the second L.

Try a larger font. It's more obvious then. Ideally, you should click in the space between the two LLs. With a small font, this is much harder to do.

rowbearto

  • Senior Community Member
  • Posts: 1167
  • Hero Points: 73
Re: RC2: Can't put cursor where I want in an xml file
« Reply #2 on: September 23, 2016, 01:21:08 am »
I tried it with a larger font, size 16, and still get the issue. I have to click between the 2 LLs multiple times until the cursor ends up there.

Between each click I do not move the mouse at all. It takes a few before the cursor is there.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4481
  • Hero Points: 344
Re: RC2: Can't put cursor where I want in an xml file
« Reply #3 on: September 23, 2016, 03:21:40 am »
What font are you using? I just used the default.

rowbearto

  • Senior Community Member
  • Posts: 1167
  • Hero Points: 73
Re: RC2: Can't put cursor where I want in an xml file
« Reply #4 on: September 23, 2016, 03:37:38 am »
I'm using default unicode font, attached is a screenshot.

Sometimes it doesn't reproduce, so I click and move the cursor to the end of a different line in the file, then move the cursor back to the end of this line, then click between the LL.

There is also some other funny behavior. If I click between the NB in NB_ANTENNAS (different line), then click between the LL in MONO_CELL, instead of placing the cursor between the 2 LL, it puts the cursor between the / and > in the final />.


rowbearto

  • Senior Community Member
  • Posts: 1167
  • Hero Points: 73
Re: RC2: Can't put cursor where I want in an xml file
« Reply #5 on: September 23, 2016, 03:40:46 am »
Now here is a weird thing. Repeat over and over a few times.

Click between the NB in NB_ANTENNAS. Cursor appears between the A and T in NB_ANTENNAS instead of between NB. Then click between the LL in MONO_CELL, cursor appears after the > sign. Repeat over and over, get similar behavior. Cursor does not go where I want.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4481
  • Hero Points: 344
Re: RC2: Can't put cursor where I want in an xml file
« Reply #6 on: September 23, 2016, 12:03:24 pm »
I'm still not getting this. It could be a font issue or it could be a timer issue.

Here's how to test if it is a timer feature causing this:

Try turning off the majority of background timers by setting the macro variable _use_timers to 0 (Macro>Set Macro Variable...). After you've either proven that it doesn't happen or does still happen, set it back to 1 or restart SlickEdit. Turning this off does break a number of features but this may help debug this problem.

rowbearto

  • Senior Community Member
  • Posts: 1167
  • Hero Points: 73
Re: RC2: Can't put cursor where I want in an xml file
« Reply #7 on: September 28, 2016, 03:27:26 pm »
On RC3 now, I tried turning off the timers (def_use_timers = 0), but still have the same issue.

It seems that it happens when I do it quickly. So if quickly click between the NB in NB_ANTENNAS, then quickly click between the 2 LL in MONO_CELL, and quickly go back and forth, I seem to have this issue. If I wait between clicking, then the issue does not occur.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4481
  • Hero Points: 344
Re: RC2: Can't put cursor where I want in an xml file
« Reply #8 on: September 28, 2016, 03:48:44 pm »
I can't reproduce this. I did up the font size because otherwise, I'm too much of a spaz with the mouse to click in the right place fast.

What kind of mouse do you have?

Are you running Windows 10?

rowbearto

  • Senior Community Member
  • Posts: 1167
  • Hero Points: 73
Re: RC2: Can't put cursor where I want in an xml file
« Reply #9 on: September 28, 2016, 03:51:00 pm »
I'm using a vanilla microsoft wired mouse on USB. Probably about 5-6 years old.

I am using windows 7.

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2171
  • Hero Points: 114
Re: RC2: Can't put cursor where I want in an xml file
« Reply #10 on: September 28, 2016, 04:02:35 pm »
Do you know the model?

rowbearto

  • Senior Community Member
  • Posts: 1167
  • Hero Points: 73
Re: RC2: Can't put cursor where I want in an xml file
« Reply #11 on: September 28, 2016, 04:10:26 pm »
On the bottom of the mouse, it shows:

P/N x802382-003
PID 56180
oem - 9862523

there is also an "0912" on the back

I found this in my amazon history for a purchase in March 2013:

https://www.amazon.com/gp/product/B005058AE8/ref=oh_aui_search_detailpage?ie=UTF8&psc=1

But not sure if it is the exact mouse I am using, as I have multiple PCs, yet only found this one record in amazon. It does look exactly like my mouse.

rowbearto

  • Senior Community Member
  • Posts: 1167
  • Hero Points: 73
Re: RC2: Can't put cursor where I want in an xml file
« Reply #12 on: September 28, 2016, 04:11:52 pm »
actually, the mouse in the picture on Amazon is missing the red light at the bottom.

I found something on ebay when searching for x802382-003

http://www.ebay.com/itm/Microsoft-Wheel-Mouse-Optical-1-1A-USB-Black-X802382-003-C16-/302040383266?nma=true&si=la1PHs72DtXgdAhQaqNFmLkD9%252BM%253D&orig_cvip=true&rt=nc&_trksid=p2047675.l2557

rowbearto

  • Senior Community Member
  • Posts: 1167
  • Hero Points: 73
Re: RC2: Can't put cursor where I want in an xml file
« Reply #13 on: September 28, 2016, 04:12:56 pm »
Here is a better link for ebay:

http://www.ebay.com/itm/Microsoft-Wheel-Mouse-Optical-1-1A-USB-Black-X802382-003-C16-/302040383266

The amazon purchase may have been an older 2013 model, but since then the amazon page is updated for newer model of this mouse?

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4481
  • Hero Points: 344
Re: RC2: Can't put cursor where I want in an xml file
« Reply #14 on: September 28, 2016, 04:19:52 pm »
I've got the same mouse as you. Pretty darn close. The mice on all my machines are old wired Microsoft mice like this one.

We can rule out the mouse. I've done most of my testing on Windows 10. I'll do some testing on Windows 7.

Try choosing a different font like "Arial" and see if there is a difference. I think the default font is "Courier New".