Author Topic: RC4: unsurround is not working properly in my source file  (Read 552 times)

rowbearto

  • Senior Community Member
  • Posts: 537
  • Hero Points: 12
RC4: unsurround is not working properly in my source file
« on: October 03, 2016, 08:14:06 pm »
I have uploaded a file to support.slickedit.com under "RC4: unsurround is not working properly in my source file"

Go to line 4515 of main.cpp. Put the cursor to the left of the opening brace. Run "unsurround". Notice that the braces are not properly removed but indenting has changed.

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 738
  • Hero Points: 32
Re: RC4: unsurround is not working properly in my source file
« Reply #1 on: October 04, 2016, 01:33:43 pm »
We'll take a look at it.  It seems to be fouled up by the trailing line comment right after the '}' for that block for some reason.  Thanks for the report.

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 738
  • Hero Points: 32
Re: RC4: unsurround is not working properly in my source file
« Reply #2 on: October 10, 2016, 01:41:29 pm »
This is going to be in the first hotfix for v21.

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 738
  • Hero Points: 32
Re: RC4: unsurround is not working properly in my source file
« Reply #3 on: October 17, 2016, 03:54:09 pm »
Confirming this is checked in for the first v21 hotfix.  Thanks again for the report.

rowbearto

  • Senior Community Member
  • Posts: 537
  • Hero Points: 12
Re: RC4: unsurround is not working properly in my source file
« Reply #4 on: October 17, 2016, 03:56:57 pm »
Thanks!