Author Topic: gui-find stuck on backward  (Read 877 times)

yakir

  • Community Member
  • Posts: 48
  • Hero Points: 2
gui-find stuck on backward
« on: October 10, 2016, 05:57:55 am »
execute gui-find:
WAD, <: find prev, < (F3): find next

execute gui-find-backward:
WAD

execute gui-find:
stuck on backward!
can't find away to return to forward

options/search/search backward = off


yakir

  • Community Member
  • Posts: 48
  • Hero Points: 2
Re: gui-find stuck on backward
« Reply #1 on: October 10, 2016, 06:05:00 am »
sorry - should have mentioned running SlickEdit Pro 2016 (v21.0.0.12 64-bit)

BTW: where can I at least reset this in a config file or location?

Graeme

  • Senior Community Member
  • Posts: 2162
  • Hero Points: 268
Re: gui-find stuck on backward
« Reply #2 on: October 10, 2016, 11:43:44 am »
In your configuration folder. 
Close slick, make a copy of vslick.sta then delete it.  Run slick and see if find works. 
If not, close slick, make a copy of vrestore.slk then delete it.  Run slick, see if find works.
If not, export all your configuration settings, close slick, rename your configuration folder to something else (as a backup), run slick then import your configuration settings.

yakir

  • Community Member
  • Posts: 48
  • Hero Points: 2
Re: gui-find stuck on backward
« Reply #3 on: October 10, 2016, 12:01:11 pm »
deleting the .sta file worked
This removed ALL my configs, luckily I had a previously saved config (pre v21)
Interestingly I had done something very similar - bur renamed .sta not deleted and it did not help (unless I made a mistake).

BTW I also tried from within the mini dialog expanding to the larger one (Ctrl-F Crl_F) unchecking the backward flag - no help

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4478
  • Hero Points: 342
Re: gui-find stuck on backward
« Reply #4 on: October 10, 2016, 12:14:57 pm »
Don't need to change your config. The new mini find dialog has two ways to change the search direction. You can press Alt+B to toggle the search direction. You can click on the down arrow button to the right of the search string text box and uncheck "Search Backward".
« Last Edit: October 10, 2016, 02:11:07 pm by Clark »

yakir

  • Community Member
  • Posts: 48
  • Hero Points: 2
Re: gui-find stuck on backward
« Reply #5 on: October 10, 2016, 03:59:35 pm »
Thanks, I know
My problem was that once I called gui-find-backward there was no way to set the default behavior to forward.