Author Topic: Turn off auto formatting anyone  (Read 3382 times)

eda

  • Community Member
  • Posts: 17
  • Hero Points: 0
Turn off auto formatting anyone
« on: November 02, 2016, 06:09:07 am »
SlickEdit does all this clever formatting and it driving me crazy. I mainly does C code.

a. It absolute wants to move my carefully formatted switch() around when I edit them. How do I stop SlickEdit from doing that.
b. Also when I do

   if () {}

   it does some formatting I do not want. I thought I found where to change but it did not work. And now I can find.

I wish I could turn all this auto formatting off. And then just turn stuff on as I like. Now keep spending time on change SlickEdit changes. And look in menus for where to change the defaults.





Tim Kemp

  • Senior Community Member
  • Posts: 537
  • Hero Points: 91
Re: Turn off auto formatting anyone
« Reply #1 on: November 02, 2016, 10:28:33 am »
There are a lot of automatic formatting controls, but I'm guessing that the ones you don't like are the same ones that bother me. The ones I turn off are in Tools->Options->Languages->Application Languages->C/C++->General. I turn off both Beautify while typing and Beautify on paste or drag and drop. I hope that helps.

eda

  • Community Member
  • Posts: 17
  • Hero Points: 0
Re: Turn off auto formatting anyone
« Reply #2 on: November 22, 2016, 11:22:54 am »
I am still have the if issue if I type

   if
and press space. It inserts

   if () {
   }

It is so annoying I am starting to look for new editor.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5714
  • Hero Points: 457
Re: Turn off auto formatting anyone
« Reply #3 on: November 22, 2016, 02:28:00 pm »
If you don't want any aliases expanded when you type keyword<space> (i.e "if<space>"), go to Tools>Options>Languages>Application Languages>C/C++>Auto-Complete and turn off "Use Syntax Expansion on space".

If you already have a C/C++ file open, an easier way to get to the C++ language options is Document>C/C++ Options>Auto-Complete.

jporkkahtc

  • Senior Community Member
  • Posts: 2159
  • Hero Points: 191
  • Text
Re: Turn off auto formatting anyone
« Reply #4 on: November 22, 2016, 09:12:53 pm »
Also, slick has notifications that give some details about features as they get invoked.
Click the little page icon in the lower right corner of the slick window to bring up the Notifications tool.

Select a notification then click the wrench icon to take to you the right place in options to control this feature.

eda

  • Community Member
  • Posts: 17
  • Hero Points: 0
Re: Turn off auto formatting anyone
« Reply #5 on: November 23, 2016, 09:39:49 am »
I tried both suggestions and restarted SlickeEdit in both cases. No change what so ever.

If you don't want any aliases expanded when you type keyword<space> (i.e "if<space>"), go to Tools>Options>Languages>Application Languages>C/C++>Auto-Complete and turn off "Use Syntax Expansion on space".

If you already have a C/C++ file open, an easier way to get to the C++ language options is Document>C/C++ Options>Auto-Complete.

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2545
  • Hero Points: 141
Re: Turn off auto formatting anyone
« Reply #6 on: November 23, 2016, 01:50:17 pm »
It still expands?  I just tested shutting this off and it definitely didn't expand for me once I had shut it off.

SlickEdit Support

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 335
  • Hero Points: 26
Re: Turn off auto formatting anyone
« Reply #7 on: November 23, 2016, 02:08:16 pm »
eda,

We sent you a PM with info how to upload your user.cfg.xml from your SlickEdit Configuration Directory.

eda

  • Community Member
  • Posts: 17
  • Hero Points: 0
Re: Turn off auto formatting anyone
« Reply #8 on: November 24, 2016, 10:18:56 am »
What is a PM. I do not seem to have gotten any email from you.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5714
  • Hero Points: 457
Re: Turn off auto formatting anyone
« Reply #9 on: November 24, 2016, 08:18:30 pm »
PM stands for Private Message. Try clicking on the "My Messages" menu item at the top of this forum page.