Author Topic: WinXP: How to add SlickEdit 2007 to the "Open With..." menu?  (Read 9681 times)

Ian

  • Community Member
  • Posts: 5
  • Hero Points: 1
I have lost all my associations on installing SE2007 and the simple minded approach of browsing to find vs.exe doesn't actually work; SlickEdit is not on the "Open With..." list and browsing to vs.exe does nothing (the file just gets opened with the "Recommended Program" if there is one, e.g. Adobe Acrobat for QAL files, which are MarketQA program scripts... really stupid).

So, is it possible to forcibly add SlickEdit 2007 to the "Open With..." context menu in Windows XP? The previous version was on there until I uninstalled it.

I know there is a similar thread about text files elsewhere on the board but my problem applies to all file types now; nothing at all opens in SE2007 and the only way to open a file is to drag and drop.

Incidentally, I can't edit my registry, it has been "disabled my my Administrator", even though I have local admin rights.

Thanks
Ian.

Phil Barila

  • Senior Community Member
  • Posts: 746
  • Hero Points: 61
Re: WinXP: How to add SlickEdit 2007 to the "Open With..." menu?
« Reply #1 on: May 07, 2007, 05:26:24 pm »
You're going to need to figure out what has disabled your Administrative rights before you can solve this.  Even though you "have local admin rights", you don't, really.  Otherwise you wouldn't have any difficulty modifying the registry.  Not being able to modify the registry is a major problem for a lot of widgets, sometimes in surprising ways.  Is your system part of a domain that you don't own?

Thom Little

  • Community Member
  • Posts: 83
  • Hero Points: 2
Re: WinXP: How to add SlickEdit 2007 to the "Open With..." menu?
« Reply #2 on: May 07, 2007, 06:18:28 pm »
As a first step ... try reloading Windows XP and see if everything that looked like it was previously missing is still missing.

... Thom

Ian

  • Community Member
  • Posts: 5
  • Hero Points: 1
Re: WinXP: How to add SlickEdit 2007 to the "Open With..." menu?
« Reply #3 on: May 10, 2007, 06:42:28 pm »
As a first step ... try reloading Windows XP and see if everything that looked like it was previously missing is still missing.

I hope you mean rebooting rather than reinstalling, when you say "reloading" ... Anyway, rebooting didn't help. I am a pretty big SlickEdit fan but not quite enough to reinstall Windows even if it was my own machine [which it is not].

I can still edit files by dragging them to the application but not by double-clicking them. I'll run this by the official support just in case it's a known bug.

Regards, Ian.

thornev

  • Community Member
  • Posts: 12
  • Hero Points: 1
Re: WinXP: How to add SlickEdit 2007 to the "Open With..." menu?
« Reply #4 on: September 16, 2008, 07:27:22 pm »
Was this problem ever solved?  I have this problem every time I update my SlickEdit - SlickEdit disappears from my "Open With..." list.

And with v13.0.2 I have a new problem which is that when I finally do open a file with SlickEdit, I get the annoying Windows prompt about the file's not being secure and do I really want to open it.

Thanks.  thorne

jimlangrunner

  • Senior Community Member
  • Posts: 358
  • Hero Points: 30
  • Jim Lang - always a student.
Re: WinXP: How to add SlickEdit 2007 to the "Open With..." menu?
« Reply #5 on: September 16, 2008, 07:42:54 pm »
If you go to Control Panel - Folder Options - File Types, you should be able to change file associations to make SlickEdit the default.  If you're having trouble with editing / changing this, why not add a shortcut to SE to the "Send To" folder.  Should be
C:\Documents and Settings\UserName\SendTo

Then, even if you can't associate a file type with Slick, you can send anything to Slick via the Send To menu.

thornev

  • Community Member
  • Posts: 12
  • Hero Points: 1
Re: WinXP: How to add SlickEdit 2007 to the "Open With..." menu?
« Reply #6 on: September 16, 2008, 08:37:06 pm »
As reported before, when I try the File Types tab and select Change to change the file associations, I browse to vs.exe, but Windows does not put it in the list of selectable apps from which to choose.

Yes, I do have SE in my Send To menu, but that doesn't help when I dbl-click in Explorer on a file.  thorne

chrisant

  • Senior Community Member
  • Posts: 1413
  • Hero Points: 131
Re: WinXP: How to add SlickEdit 2007 to the "Open With..." menu?
« Reply #7 on: September 16, 2008, 11:40:48 pm »
Are you using Vista?  Maybe you need to right click on the SlickEdit program and choose "Run as Administrator" to run it with elevated privileges for it to successfully update the file type associations?

witness9

  • Community Member
  • Posts: 54
  • Hero Points: 2
Re: WinXP: How to add SlickEdit 2007 to the "Open With..." menu?
« Reply #8 on: September 17, 2008, 12:50:53 pm »
For what its worth, I have this problem too.  I'm on XP-pro, SlickEdit Version 13.0.1.0.

I work around it by adding the file types through SlickEdit; Tool/Options-File Options-Associate File Types.

Mike

  • SlickEdit Team Member
  • Community Member
  • *
  • Posts: 98
  • Hero Points: 19
Re: WinXP: How to add SlickEdit 2007 to the "Open With..." menu?
« Reply #9 on: September 17, 2008, 02:13:38 pm »
This looks related to the problem addressed in:
http://community.slickedit.com/index.php?topic=742.0

thornev

  • Community Member
  • Posts: 12
  • Hero Points: 1
Re: WinXP: How to add SlickEdit 2007 to the "Open With..." menu?
« Reply #10 on: September 19, 2008, 01:13:26 pm »
I'm not on Vista; I'm on Win XP + SP3.  I did read that other thread, but the suggestions did not help although yes, adding file associations through SE does help.  But as I said, THEN I get those annoying Windows prompts where I'm asked to continue because the publisher is unkown ("Open File - Security Warning" is the title of the dialog).  I'll go Google on that dialog and see how to get rid of them.  thorne

thornev

  • Community Member
  • Posts: 12
  • Hero Points: 1
Re: WinXP: How to add SlickEdit 2007 to the "Open With..." menu?
« Reply #11 on: September 19, 2008, 01:55:31 pm »
Found a fix that works (i.e. gets rid of the "unknown publisher" prompt):

1. Opened Internet Options Dialog Box from IE7
2. Selected Security Tab
3. Selected 'Local Intranet' icon from the zones shown
4. Clicked on 'Sites' command button, which opened a 'Local Intranet' Dialog Box
5. Clicked on 'Advanced' command button, which opened a dialog box where you are able to add and remove websites from your intranet.
6. Add "\\servername\" to list of websites. Click 'Close, then 'OK' to return to main Internet Options Dialog Box.
« Last Edit: September 19, 2008, 03:16:29 pm by thornev »

jimlangrunner

  • Senior Community Member
  • Posts: 358
  • Hero Points: 30
  • Jim Lang - always a student.
Re: WinXP: How to add SlickEdit 2007 to the "Open With..." menu?
« Reply #12 on: September 22, 2008, 03:57:00 pm »
Okay, this isn't "Open With", but it may help a little.

Browsing another topic (http://community.slickedit.com/index.php?topic=3601.0) and found that you can drop a file on the SlickEdit window to open the file, even files not associated with Slick.  It hadn't occured to me before, so I tried it.  It works.  I thought it may help a bit.  This works if you drop on an open slickedit Window or the slickedit shortcut on the desktop or in the quicklaunch toolbar.

Hope it helps.