Author Topic: SIGUSR1 SIGUSR2 again / configuration of gdb under Windows  (Read 1022 times)

ikke noe

  • Junior Community Member
  • Posts: 5
  • Hero Points: 0
SIGUSR1 SIGUSR2 again / configuration of gdb under Windows
« on: February 06, 2017, 03:37:31 pm »
Dear Readers ,
I am remote debugging with gdb.
The debugee runs under Linux, the client under Windows.
I use SIGUSR1 and SIGUSR2 in my application.
Although I read
http://community.slickedit.com/index.php/topic,7299.0.html
and more I do not see any other chance than to enter
debug-send-command handle SIGUSR2 nostop noprint
debug-send-command handle SIGUSR1 nostop noprint
every time at the command line.
 How do I have to configure gdb under Windows, that it reads and executes a command file?
Regards
ikke noe

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2204
  • Hero Points: 275
Re: SIGUSR1 SIGUSR2 again / configuration of gdb under Windows
« Reply #1 on: February 10, 2017, 03:02:00 pm »
Debug > Debugger Options... > Configurations

Select the GDB that you are using for remote debugging.
Add arguments  -x "<path_to_command_file>"
Hit OK.

ikke noe

  • Junior Community Member
  • Posts: 5
  • Hero Points: 0
Re: SIGUSR1 SIGUSR2 again / configuration of gdb under Windows
« Reply #2 on: February 22, 2017, 04:21:16 pm »
Hi Dennis,
unfortunately it doesn't work.
In the attachment you can see the command line.
The quotation marks are omitted by unknown.
The file exists and looks like:

debug-send-command SIGUSR2 pass nostop noprint
debug-send-command SIGUSR1 pass nostop noprint
handle SIGUSR1 pass nostop noprint
handle SIGUSR2 pass nostop noprint


Nevertheless I can only get rid of the messages if I enter them at the vs command line.
Any other option?
Regards
ikke noe