Author Topic: All command always shows line 1  (Read 1820 times)

lhasadad

  • Community Member
  • Posts: 15
  • Hero Points: 3
All command always shows line 1
« on: February 22, 2017, 03:55:13 pm »
Bit of an oddity in SlickEdit Pro 2016 (v21.0.1.0 64-bit)
with hotfix_se2101_1_cumulative.zip (Revision: 1)
applied

Note, I have seen the this behavior in earlier releases, so not specific to this hotfix.

I use the 'all'  command to show only lines with a string in it.   for some reason the selective display that it results in always winds up showing me line 1 even though line 1 does not have the string.   the rest of the lines are correct.   its not a big deal but reporting it so you guys can get it corrected in future hotfix or release.

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2545
  • Hero Points: 141
Re: All command always shows line 1
« Reply #1 on: February 22, 2017, 05:19:58 pm »
I am looking into this, but I am not sure if we can change it.

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2545
  • Hero Points: 141
Re: All command always shows line 1
« Reply #2 on: February 22, 2017, 07:46:17 pm »
We have to show at least one line, so that's why line 1 is there.  We may be able to change this in the future so that it only shows line 1 if no other matches are found, but it is not a trivial change.

If you go to Tools>Options and choose Appearance>General and turn "Top of file line" on, you won't get this behavior (because the "Top of file line" (sometimes called line 0) is still displayed).  You may have to exit the editor to get this to take effect.  The Top of file line is off by default now in most emulations because it seems a bit dated, but there are some advantages to it.

lhasadad

  • Community Member
  • Posts: 15
  • Hero Points: 3
Re: All command always shows line 1
« Reply #3 on: February 23, 2017, 12:38:59 am »
Dan,

Will try the top of line option that seems a reasonable compromise.