Author Topic: Cross-reference search is missing usage of member variable in constructor  (Read 484 times)

rowbearto

  • Senior Community Member
  • Posts: 793
  • Hero Points: 25
I have a case where a cross-reference search is missing usage of member variable in a C++ constructor.

To reproduce:

I uploaded a sample project to support.slickedit.com, the file name is:
swbug.7z

Unzip it and open the workspace.

Go to line 741 of StackWalker.cpp and highlight "m_stackLogFile".

Press Ctrl+/

You will notice that the places where m_stackLogFile is used in the constructor (lines 741 and 745) are not in the cross-reference output :(.

Note that this code compiles fine. I did not include all the source files needed to compile, nor the makefile, but I think what I provided is sufficient, SE should be finding the references at lines 741 and 745, but it is not.

I am using 21.0.2 on windows x64 with hotfix_se2102_11_cumulative.zip.

Thanks for taking a look,
Rob
« Last Edit: April 21, 2017, 03:41:41 am by rowbearto »

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2244
  • Hero Points: 282
Got your project and reproduced the problem.  Thanks very much for the good example.  I'll see what I can do.  This may have to wait for 21.0.3.

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2244
  • Hero Points: 282
This will be fixed in the next hot fix for 21.0.2.

rowbearto

  • Senior Community Member
  • Posts: 793
  • Hero Points: 25
Thanks!